Go Back   Aquarium Advice - Aquarium Forum Community > Freshwater > Cichlid Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-15-2013, 01:19 AM   #1
Aquarium Advice Newbie
 
Brianstark74's Avatar
 
Join Date: Jun 2013
Posts: 4
Help.... New tank

I just bought a 55 gallon set up and new convicts. My water is constantly cloudy. Water is treated, chemicals should be balanced but clouds back up within a day. What should one doing?
__________________

__________________
Brianstark74 is offline   Reply With Quote
Old 06-15-2013, 01:28 AM   #2
Aquarium Advice Addict
 
erikmoseley's Avatar
 
Join Date: Jan 2013
Location: Boston
Posts: 1,265
Did you cycle the tank? Have you tested the water condition? If so what are the parameters?
__________________

__________________
erikmoseley is offline   Reply With Quote
Old 06-15-2013, 01:30 AM   #3
Aquarium Advice FINatic
 
Jakepen's Avatar
 
Join Date: Mar 2013
Posts: 551
Probably just need patience, depending on what you used for substrate, it's most likely stirred up. Took mine almost two days until it was crystal.
__________________
Jakepen is offline   Reply With Quote
Old 06-15-2013, 10:27 AM   #4
Aquarium Advice Newbie
 
Brianstark74's Avatar
 
Join Date: Jun 2013
Posts: 4
No I haven't tested the water. Testing supplies are expensive. Is it a must to test?
__________________
Brianstark74 is offline   Reply With Quote
Old 06-15-2013, 11:06 AM   #5
Aquarium Advice FINatic
 
Jakepen's Avatar
 
Join Date: Mar 2013
Posts: 551
Quote:
Originally Posted by Brianstark74 View Post
No I haven't tested the water. Testing supplies are expensive. Is it a must to test?
It's kind of crucial. API freshwater master test kit. It's like 30 dollars, tests very accurate all the levels you need to monitor. Get it. Since you don't have testing supplies I'm gonna guess you didn't cycle the tank before you added fish?
__________________
Jakepen is offline   Reply With Quote
Old 06-17-2013, 02:25 PM   #6
Aquarium Advice Newbie
 
Brianstark74's Avatar
 
Join Date: Jun 2013
Posts: 4
No, I didn't. Got into a big hurry and didn't do any research. Big mistake. Ive cycled the water three times. Also I added air bubbles. So far so good.
__________________
Brianstark74 is offline   Reply With Quote
Old 06-17-2013, 02:33 PM   #7
Aquarium Advice Regular
 
Bazza7's Avatar
 
Join Date: Jun 2013
Posts: 70
Sounds silly but did you thoroughly wash the gravel?
__________________
Bazza7 is offline   Reply With Quote
Old 06-17-2013, 02:38 PM   #8
Aquarium Advice Newbie
 
Brianstark74's Avatar
 
Join Date: Jun 2013
Posts: 4
No I didn't.
__________________
Brianstark74 is offline   Reply With Quote
Old 06-17-2013, 02:40 PM   #9
Aquarium Advice Regular
 
Bazza7's Avatar
 
Join Date: Jun 2013
Posts: 70
New gravel creates lots of particles in the water. Will just take longer to clear.
__________________

__________________
Bazza7 is offline   Reply With Quote
Reply

Tags
tan

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








All times are GMT -4. The time now is 03:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.