Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 05-29-2012, 04:35 PM   #41
Aquarium Advice Regular
 
Saltwaterman's Avatar
 
Join Date: May 2012
Posts: 98
Umm it did happen overnight and it stayed but I'll read what you gave here thanks
__________________

__________________
Saltwaterman is offline   Reply With Quote
Old 05-29-2012, 04:38 PM   #42
Aquarium Advice Regular
 
Saltwaterman's Avatar
 
Join Date: May 2012
Posts: 98
Well I've been doing all those steps except the water changes which I do every two weeks
__________________

__________________
Saltwaterman is offline   Reply With Quote
Old 05-29-2012, 04:47 PM   #43
SW REEF 18+ YEARS
Community Admin
 
melosu58's Avatar



Tank of the Month Award
 
Join Date: Oct 2004
Location: Virginia
Posts: 38,249
I would do PWC`s twice a week and when you do them siphon out as much as that algea that you can. You`ll be removing the algea and reducing the excessive nutrients at the same time. Kind of like getting two birds with one stone. I would say after a month you`ll notice a big difference.
__________________

SITE ADMINISTRATOR

You can view many of my fish and corals in my photo albums in my profile.

View my tank


AA Community Rules|AA TOS

Forums 101 - posting, accounts, basics
melosu58 is offline   Reply With Quote
Old 05-30-2012, 08:20 PM   #44
Aquarium Advice Apprentice
 
Join Date: Apr 2011
Location: Alberta
Posts: 27
Hey all. I'm having the same problem in my 90. I am a lot worse off tho. Any more aggressive treatments you can think of?!
Attaching this pic. Pls help
Click image for larger version

Name:	image-574672520.jpg
Views:	57
Size:	173.5 KB
ID:	97777
__________________
Oilerfan is offline   Reply With Quote
Old 05-30-2012, 08:35 PM   #45
Aquarium Advice Regular
 
Saltwaterman's Avatar
 
Join Date: May 2012
Posts: 98
Hey we both have something in common, algae and Olier fan.
__________________
Saltwaterman is offline   Reply With Quote
Old 05-30-2012, 08:47 PM   #46
Aquarium Advice Regular
 
Saltwaterman's Avatar
 
Join Date: May 2012
Posts: 98
And I can't find the algae?
__________________
Saltwaterman is offline   Reply With Quote
Old 05-31-2012, 06:36 PM   #47
Aquarium Advice Apprentice
 
Join Date: Apr 2011
Location: Alberta
Posts: 27
The algae in my pic is everywhere you see very dark carpets with white patches of rock peeking through. It's BAD. I'm thinking of getting rid of my hang-on aquaclear 110 altogether and maybe going to a sump/fuge system. But that's a big project! Plus my skimmer isn't skimming properly. I'm almost sure the problem lies there. But the algae originated in my father-in laws tank and I transplanted most of his stuff. FML!....
__________________
Oilerfan is offline   Reply With Quote
Old 05-31-2012, 06:36 PM   #48
Aquarium Advice Apprentice
 
Join Date: Apr 2011
Location: Alberta
Posts: 27
Go oilers go!!!! Lol
__________________
Oilerfan is offline   Reply With Quote
Old 05-31-2012, 07:07 PM   #49
Aquarium Advice Addict
 
Readingexcalibur's Avatar
 
Join Date: Dec 2011
Location: Las Vegas
Posts: 1,305
Quote:
Originally Posted by Oilerfan
The algae in my pic is everywhere you see very dark carpets with white patches of rock peeking through. It's BAD. I'm thinking of getting rid of my hang-on aquaclear 110 altogether and maybe going to a sump/fuge system. But that's a big project! Plus my skimmer isn't skimming properly. I'm almost sure the problem lies there. But the algae originated in my father-in laws tank and I transplanted most of his stuff. FML!....
I got this algae when I mixed my own salt without using RODI. Hard to get out, won't make that mistake again.
__________________
"When you're down by the sea and an eel bites your knee... That's a Moray"
Readingexcalibur is offline   Reply With Quote
Old 06-01-2012, 04:27 PM   #50
Aquarium Advice Regular
 
Saltwaterman's Avatar
 
Join Date: May 2012
Posts: 98
I went and bought my self the phosphate kit and the nitrate kit. What levels should both be at?
__________________

__________________
Saltwaterman is offline   Reply With Quote
Reply

Tags
algae

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 09:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.