Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 01-08-2013, 06:15 PM   #1
Aquarium Advice FINatic
 
Elykreefs97's Avatar
 
Join Date: Sep 2012
Posts: 593
Algea problem?

Do I have an algea problem. I have a turbo snail but all he does is clear off my live rock I hate it. Is it just going through a cycle it's only been 4 weeks since start up.
Attached Thumbnails
Click image for larger version

Name:	image-1813815769.jpg
Views:	70
Size:	134.3 KB
ID:	142774  
__________________

__________________
Elykreefs97 is offline   Reply With Quote
Old 01-08-2013, 06:18 PM   #2
Aquarium Advice Addict
 
mr_X's Avatar


 
Join Date: Apr 2008
Location: Fairless Hills, Pa.
Posts: 17,895
Send a message via MSN to mr_X
It's a diatom bloom. Completely normal in a new tank. 4 weeks and you have an anemone? That specimen is badly bleached out also.
__________________

__________________
thanks,
Doug
mr_X is offline   Reply With Quote
Old 01-08-2013, 06:24 PM   #3
Aquarium Advice FINatic
 
Elykreefs97's Avatar
 
Join Date: Sep 2012
Posts: 593
The tank is older than that really bc my 10 gal was 6 months old and all the water, sand, rock, and filter media are on the tank it's cycled just going through this but yea the nem was from petco he was bleached when I bought him he's slowly recovering. I did have a green BTA but his foot was badly damaged when my LFS sold him to me guess I should have checked him out first. I also have some Zoas Palys and pulsing Xenia in there doing fine.
__________________
Elykreefs97 is offline   Reply With Quote
Old 01-08-2013, 06:35 PM   #4
Aquarium Advice FINatic
 
Elykreefs97's Avatar
 
Join Date: Sep 2012
Posts: 593
And this is my 29 gal.
__________________
Elykreefs97 is offline   Reply With Quote
Old 01-08-2013, 11:09 PM   #5
Aquarium Advice Activist
 
Join Date: Nov 2012
Posts: 142
I have biocube 29 and getting the same. Used tap but going to RO now. Any idea how long it might last?
__________________
paulr is offline   Reply With Quote
Old 01-09-2013, 01:09 AM   #6
Aquarium Advice Addict
 
Phranque's Avatar

POTM Champion
 
Join Date: Sep 2011
Location: Miamisburg, OH
Posts: 1,443
Quote:
Originally Posted by paulr View Post
I have biocube 29 and getting the same. Used tap but going to RO now. Any idea how long it might last?
Depends on the silica availability, especially using tap..... typically a few weeks.
__________________

__________________
Wanna calculate the cost of that new reef tank?? Take your worst nightmare, double it, and you're halfway there.
Phranque is offline   Reply With Quote
Reply

Tags
algea

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 04:01 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.