Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-12-2014, 10:48 PM   #1
Aquarium Advice Activist
 
Scotty Fraiser's Avatar
 
Join Date: Mar 2013
Posts: 175
Quick rodi question

Changed every filter on my 4 stage rodi system. The system was 2 years old. Filtering 25 gall every other week. Anyway, now my tds meter is reading 33 coming out. All filters seem to be seated properly. 50 gall of filtered water has been passed through. Any thoughts or suggestions. ???
__________________

__________________
Scotty Fraiser is offline   Reply With Quote
Old 06-12-2014, 11:03 PM   #2
Aquarium Advice Regular
 
Smoothmullet's Avatar
 
Join Date: Nov 2013
Posts: 71
Inline Tds meter? Check the probes and wipe them with a paper towel what's it going in?
__________________

__________________
Smoothmullet is offline   Reply With Quote
Old 06-12-2014, 11:30 PM   #3
Aquarium Advice Activist
 
Scotty Fraiser's Avatar
 
Join Date: Mar 2013
Posts: 175
Yes. An inline tds meter. It has always been around 325 going in. Usually 2 to 5 coming out.
__________________
Scotty Fraiser is offline   Reply With Quote
Old 06-12-2014, 11:58 PM   #4
Aquarium Advice Addict
 
Mattyfelts's Avatar
 
Join Date: Sep 2013
Location: Ontario, Canada
Posts: 2,111
usually you have to run the new filters a couple of times first before reading 0. Or so i have heard
__________________
60G Freshwater || 10G Reef
Instagram: MATTYFELTS
Mattyfelts is offline   Reply With Quote
Old 06-13-2014, 12:08 AM   #5
Aquarium Advice Activist
 
Scotty Fraiser's Avatar
 
Join Date: Mar 2013
Posts: 175
I did. Let it filter for 12 hours and the numbers are the same.
__________________
Scotty Fraiser is offline   Reply With Quote
Old 06-13-2014, 12:43 AM   #6
Aquarium Advice Regular
 
Smoothmullet's Avatar
 
Join Date: Nov 2013
Posts: 71
Do you have it hooked up one after the membrane and the other after di. That's the way to go then you can see how much is removed thru the first three then what the di removes. Sounds like you have it before the sediment filter then after membrane.
__________________
Smoothmullet is offline   Reply With Quote
Old 06-13-2014, 02:20 AM   #7
Aquarium Advice Addict
 
jeffaquarius's Avatar
 
Join Date: Jan 2013
Location: Los Angeles, California
Posts: 1,933
Remove the DI cartridge or media and flush the RO until you get less than 40 tds. Reinstall back the DI and double check tightness. You might have a bad seal.
__________________
"Nothing great in the world has ever been accomplished without passion". George Wilhelm Friedrich Hegel

http://www.youtube.com/watch?v=90w86...A434PW3gEa1-QA
jeffaquarius is offline   Reply With Quote
Old 06-13-2014, 06:41 PM   #8
Aquarium Advice Activist
 
Scotty Fraiser's Avatar
 
Join Date: Mar 2013
Posts: 175
Sorry for the slow response. Will take them all loose and look at seals and try again. Will also wipe off probes. Should the tds meter ever need calibrating?
__________________
Scotty Fraiser is offline   Reply With Quote
Old 06-13-2014, 07:17 PM   #9
Aquarium Advice Apprentice
 
bgallagher's Avatar
 
Join Date: Dec 2013
Posts: 13
I had the same thing happen recently... My newly installed DI cartridge was up side down...


Brett
__________________
bgallagher is offline   Reply With Quote
Old 06-14-2014, 04:40 PM   #10
Aquarium Advice Activist
 
Scotty Fraiser's Avatar
 
Join Date: Mar 2013
Posts: 175
Yep!!!! Di canister was upside down. Thanks for the replys. Crappie water means lots of water changes over the next month! Woohoo
__________________

__________________
Scotty Fraiser is offline   Reply With Quote
Reply

Tags
ick, question, rodi

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RODI question? edwardclaxton Saltwater Reef Aquaria 7 09-02-2012 10:40 AM
Quick Question seeking eligible Quick Answer Cynic Freshwater & Brackish - Getting Started 5 12-13-2011 09:35 PM
rodi system question rob_mango General Hardware/Equipment Discussion 20 11-17-2011 06:35 PM
one more RODI question degbowl General Hardware/Equipment Discussion 3 02-19-2006 02:01 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.