Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-19-2011, 08:05 AM   #11
Aquarium Advice Freak
 
Scotty09's Avatar
 
Join Date: Feb 2011
Posts: 315
I don't think it really growing At all just a few patches
__________________

__________________
Scotty09 is offline   Reply With Quote
Old 11-22-2011, 11:07 PM   #12
Aquarium Advice Regular
 
Join Date: May 2011
Location: Long Island
Posts: 54
Same problem... Slow battle that was taking over. No matter how many water changes I did and shortening light hours, it would come back within 1-2 days. My LFS sold me "ultra life red slime remover" best stuff I ever used. 12 hours in I saw a difference, 24-36 hours it was ALL GONE. I had this stuff all over live rock and sand. I couldn't believe that's all it took this whole time.
__________________

__________________
shamrock13 is offline   Reply With Quote
Old 11-23-2011, 07:01 AM   #13
Aquarium Advice Freak
 
Scotty09's Avatar
 
Join Date: Feb 2011
Posts: 315
Can this be brought in uk
__________________
Scotty09 is offline   Reply With Quote
Old 11-23-2011, 07:32 AM   #14
Aquarium Advice Regular
 
wapparia's Avatar
 
Join Date: Nov 2011
Location: Newcastle, England
Posts: 81
yes. i have just looked and it can be bought from ebay.co.uk. i am not sure were in uk you are but dobbies garden centres up north are the best place to get anything marine (just check because odd one don't have aquatics) can be slightly more expensive from dobbies than if you find local lfs who supply it.
__________________
wapparia is offline   Reply With Quote
Old 11-23-2011, 10:59 AM   #15
Aquarium Advice Freak
 
Scotty09's Avatar
 
Join Date: Feb 2011
Posts: 315
Thxs mate ur a legend !!!
__________________
Scotty09 is offline   Reply With Quote
Old 11-23-2011, 12:41 PM   #16
Aquarium Advice Addict
 
Join Date: Aug 2005
Location: Chicago
Posts: 1,020
Send a message via Yahoo to jcarlilesiu
Keep in mind that often times phosphates read zero because the algae is uptaking the nutrients (and growing) giving you a false zero reading.

Phosphates are being introduced into the tank somewhere. From food, water changes, etc.

Eliminate those and the red slime will die.
jcarlilesiu is offline   Reply With Quote
Old 11-23-2011, 12:55 PM   #17
Aquarium Advice Freak
 
Scotty09's Avatar
 
Join Date: Feb 2011
Posts: 315
So phosphate testing is unless then ? And I think I got it under control just need something to tip me over the edge. I think it was from my skimmer being blokes for 2-4 weeks
__________________
Scotty09 is offline   Reply With Quote
Old 11-23-2011, 01:01 PM   #18
Aquarium Advice Addict
 
Join Date: Aug 2005
Location: Chicago
Posts: 1,020
Send a message via Yahoo to jcarlilesiu
Quote:
Originally Posted by Scotty09 View Post
So phosphate testing is unless then ? And I think I got it under control just need something to tip me over the edge. I think it was from my skimmer being blokes for 2-4 weeks
I don't think testing phosphates is worthless, but it may not be helpful in finding the problem.

Also, using like an API test kit isn't going to find the really low readings of phosphates which can also contribute to algae growth.

If I see algae, i figure i have phosphates and take action to reduce them.
jcarlilesiu is offline   Reply With Quote
Old 11-23-2011, 01:03 PM   #19
Aquarium Advice FINatic
 
catmel's Avatar


 
Join Date: Apr 2008
Location: Findlay, Ohio
Posts: 660
Send a message via AIM to catmel
Make sure you look around for any 'pockets' of crud laying around the tank ( usea turkey baster to blast rocks, etc) I found a lot if hidden junk wit hmy water flow not being great.. that once I started to get rid of it, it slowly went away ( or diminished a lot at least)
__________________
75 Gallon Saltwater Reef

Just your average LVT (licenced vet tech) trying to help the world's animals!!
- Melinda
catmel is offline   Reply With Quote
Old 11-23-2011, 02:14 PM   #20
Aquarium Advice Addict
 
Animal-Chin's Avatar

Tank of the Month Award
 
Join Date: Nov 2011
Location: Vancouver BC
Posts: 1,315
this is the stuff I used, I have no idea if you can get it in the UK but it's available in Canada. Check with your local store...

Boyd Enterprises Chemi-Clean Saltwater Conditioner Red Slime Remover | PetFoodDirect


I treated my tank once and in 2 days it was completely gone. Not just dead, it actually dissapears. You're skimmer will go nuts for a few days though so keep a real good eye on it, I had to empty it evey hour for a day or two.
__________________

__________________
Animal-Chin is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Killed hair algae now battling redslime help Scotty09 Saltwater Reef Aquaria 33 11-16-2011 04:45 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 03:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.