Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-28-2004, 12:54 AM   #1
Aquarium Advice Regular
 
Join Date: May 2004
Posts: 82
stupid algae

i have a 55 gallon, had it for about 7-8 months and i still have a red or brown algae problem. i cant seem to get rid of it all levels r normal only one i dont know is phosphates which i have been told could be the main reason but i have anemones and corals so i cant use anything to kill them but what else can i do to get rid of the pesky algae?
__________________

__________________
mandarin man is offline   Reply With Quote
Old 06-28-2004, 01:46 AM   #2
Aquarium Advice Freak
 
Join Date: Jun 2004
Location: West Lafayette IN
Posts: 222
a clean up crew! look into various snails/hermits or even fish that eat whatever algea you need to remove
__________________

__________________
Saltwater:
55 gal FOWLR
Euro-reef 5-2 skimmer, 29 gallon sump
3x penguin 1140 ph
2x65 10,000K and 2x65 03 Acintic
40lbs cc/30lbs argonite sand mixture
80lbs keys rock (www.liverocks.com awesome stuff)
25lbs fiji/tonga lr
10lbs lace base rock (now hapily live with lots of coraline growth)
lziarek is offline   Reply With Quote
Old 06-28-2004, 09:29 AM   #3
Aquarium Advice Apprentice
 
Join Date: May 2004
Location: Colorado
Posts: 51
Send a message via Yahoo to lad2knowu
If you are using tap water for your top offs and water changes...Stop. Start using RO/DI water. A cleanup crew is a good idea. Also, if your not using a skimmer you might invest in one. More info on your tank would be helpful
__________________
Eddie
lad2knowu is offline   Reply With Quote
Reply

Tags
algae

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
stupid me! mike47517 Freshwater & Brackish - General Discussion 53 10-12-2008 05:26 PM
I am soooo stupid...I created my own algae problem MiamiCuse Freshwater & Brackish - Planted Tanks 1 09-12-2008 10:56 PM
Stupid me, another stupid mistake. WaterPond Freshwater & Brackish - General Discussion 2 08-14-2006 12:42 PM
Stupid! Stupid! Stupid! (Me, not the fish) QTOFFER Freshwater & Brackish - General Discussion 4 01-19-2004 09:33 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 06:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.