Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 03-30-2016, 02:31 PM   #1
Aquarium Advice Activist
Join Date: Mar 2015
Posts: 108
Tank not cycling!? 20 gallon long.

This is my first saltwater tank and I was really excited to set it up. My tank has been set up for three weeks now. I only use RO water, I cant afford an RO/DI unit. I've added a cube of brine shrimp to get the cycle started. Ammonia was at 2 ppm I'm using a cheap internal filter cause I can't afford a sump (I'm 14). My temperature is set at 82, I've added dry rock, I added beach sand a week ago. I tested the sand and there were no phosphates and it did not affect my ph. There is a lot of gas exchange from my poweheads. I don't run my lights because I was told it wasn't necessary. I've been adding doses of Microbacter7 for a week now and my ammonia is still at 2 ppm, nitrites 0 ppm, nitrates 0 ppm. I'd sometimes get .25 nitrites but never nitrates. I had a temperature swing from 82 to 70 last night because someone unplugged my heater. What is going on!? I'm starting get really frustrated. Is there something I'm doing wrong?

Ammonia - 2 ppm
Nitrites - 0 ppm
Nitrates - 0 ppm
pH - 8.4
SG - 1.025

Here are photos of the tank.
Postimage.org / gallery - IMG 0664, IMG 0665

dulcisveteranus is offline   Reply With Quote
Old 03-30-2016, 07:32 PM   #2
Aquarium Advice Freak

POTM Champion
Tank of the Month Award
Join Date: Oct 2015
Location: Norwich UK
Posts: 352
Add a small piece of live rock to help kickstart the system better and then it is just a case of time I'm afraid.
Marty.h is offline   Reply With Quote

20 gallon, cycling, gallon, long, tan, tank

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
56 gallon column tank not long enough for africans? Fishobsessed7 Cichlid Discussion 5 07-30-2015 03:48 PM
30 gallon long vs 40 gallon long Penguin Freshwater & Brackish - General Discussion 34 03-05-2015 06:58 AM
Cycling not cycling Gibberwatt Freshwater & Brackish - Getting Started 9 07-20-2014 04:07 PM
Confused on cycling (not cycling) DrHockey Freshwater & Brackish - General Discussion 1 03-22-2014 06:28 PM
Bioload/ Live Aquaria/ Cycling 20 Gallon Long Jakester42 Freshwater & Brackish - Getting Started 2 02-05-2014 03:26 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 03:51 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.