Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater Reef Aquaria
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 09-21-2004, 10:53 AM   #1
Aquarium Advice Freak
 
Join Date: Jan 2004
Location: San Diego
Posts: 215
Turboflotor 1000 Problems

I just recently purchased a Turboflotor 1000 skimmer. I bought the Ocean Runner 2700 pump upgrade to go with it instead of the Rio. Has anyone else had problems setting this up to work or is it just my stupidity? The instructions are horrible! The pump has one of those needle wheels inside, which IMO seems to me not to provide enough flow. I set it up in my kitchen sink first to see how it works and the skimmer only produces extremely large bubbles and only fills the skimmer reaction chamber with water about half way. The intake for the pump recirculates some water from inside the skimmer and also takes new water from outside (kind of a dual intake), but most of the water seems to be drawn from inside the skimmer rather than the external source. I can't feel any suction from the external intake pipe. What am I doing wrong??
__________________

__________________
For since the creation of the world God's invisible qualities...have been clearly seen, being understood from what has been made, so that men are without excuse. (Romans 1:20)
johnkristie is offline   Reply With Quote
Old 09-21-2004, 04:31 PM   #2
Aquarium Advice Addict
 
Join Date: Dec 2003
Location: Rosemount, MN
Posts: 1,091
Send a message via AIM to WarOrks15 Send a message via MSN to WarOrks15
well yes teh instructions are really bad. but i have finaly got the thing to work my biggest problem was what needle wheel to use. but the skimmer will only make the small bubbles that remove stuff in salt water.

did you get the hob or the sump one?

if the sump one use a mj 600 for the pump to pump water in to the inlet tube. and then hook up the other pump so it sucks water from the skiller and air line and shoots is back in to the skimmer.

i hop this helps. there is another person that helped me with this skimmer but i forget his name. he was a great help to me nd i will try to do my best to help you.
__________________

__________________
A 46 gal bow front (Soft coral) reef tank with a 10 gal sump. And a 30 gal (SPS and Clam) reef tank hooked up to the sump of the 46 so they share water.
WarOrks15 is offline   Reply With Quote
Old 09-21-2004, 09:47 PM   #3
Aquarium Advice Freak
 
Join Date: Jan 2004
Location: San Diego
Posts: 215
I've got the sump one. I don't really follow you. Are you saying I should get another submersible to pump water into my original pump? And what is a mj 600?
__________________
For since the creation of the world God's invisible qualities...have been clearly seen, being understood from what has been made, so that men are without excuse. (Romans 1:20)
johnkristie is offline   Reply With Quote
Old 09-21-2004, 11:23 PM   #4
Aquarium Advice Addict
 
Join Date: Dec 2003
Location: Rosemount, MN
Posts: 1,091
Send a message via AIM to WarOrks15 Send a message via MSN to WarOrks15
ok so you have an inlet to the skimmer, right? it is a long gray tube that is about a ft long or so. well take some 1/2" id tube and stick one end to that tube and the other to the out put of a maxi-jet 600. this will pump water in to the skimmer to get skimmed.

and are you sure that you have the pump (the ocean runner) sucking water from the skimmer and sending it back to it in one loop? if you take a look on www.marinedepot.com they have a good pic of what it should look like.

they say that you can hook the skimmer to the drain line coming from the over flow but that would be way too much flow and if is not able to suck up water in the inlet tube. you have to pump it in there. you can use any pump that will pump like 100 gph or so. i just got a maxi-jet 600 and it works great. you do not need a ball valve for it or any thing.

dose this help some?
__________________
A 46 gal bow front (Soft coral) reef tank with a 10 gal sump. And a 30 gal (SPS and Clam) reef tank hooked up to the sump of the 46 so they share water.
WarOrks15 is offline   Reply With Quote
Old 09-21-2004, 11:43 PM   #5
Aquarium Advice Addict
 
Join Date: Dec 2003
Location: Rosemount, MN
Posts: 1,091
Send a message via AIM to WarOrks15 Send a message via MSN to WarOrks15
o the maxi-jet 600 is rated for 160 not 100. so if you got a pump rated at about tat it would work.
__________________
A 46 gal bow front (Soft coral) reef tank with a 10 gal sump. And a 30 gal (SPS and Clam) reef tank hooked up to the sump of the 46 so they share water.
WarOrks15 is offline   Reply With Quote
Old 09-22-2004, 09:23 PM   #6
Aquarium Advice Freak
 
Join Date: Jan 2004
Location: San Diego
Posts: 215
I tried your solution WarOrk and still have no luck. I think it might be that the venturi is screwed up. But at least the skimmer fills with water now. Just still have extremely large bubbles in the skimmer. Does yours have the intake from the overflow and the intake from the skimmer being drawn into the pump from the same T-joint?
__________________
For since the creation of the world God's invisible qualities...have been clearly seen, being understood from what has been made, so that men are without excuse. (Romans 1:20)
johnkristie is offline   Reply With Quote
Old 09-24-2004, 03:54 PM   #7
Aquarium Advice Addict
 
Join Date: Dec 2003
Location: Rosemount, MN
Posts: 1,091
Send a message via AIM to WarOrks15 Send a message via MSN to WarOrks15
yes. there is a t joint that takes water from the mj 600 and the skimmer. did you try the other needle wheel? there are 2 of them in that box and i tryed one and it had bigger bubbles then the 2nd one i tryed.
__________________
A 46 gal bow front (Soft coral) reef tank with a 10 gal sump. And a 30 gal (SPS and Clam) reef tank hooked up to the sump of the 46 so they share water.
WarOrks15 is offline   Reply With Quote
Old 09-24-2004, 06:13 PM   #8
Aquarium Advice Freak
 
Join Date: Jan 2004
Location: San Diego
Posts: 215
I've only tried the one that came on the pump. Mainly because I can't get it off to try the other one! I'm getting fairly frustrated with this thing.
__________________

__________________
For since the creation of the world God's invisible qualities...have been clearly seen, being understood from what has been made, so that men are without excuse. (Romans 1:20)
johnkristie is offline   Reply With Quote
Reply

Tags
oto

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aqua Medic Turboflotor 1000 Multi - 1st impression cmor1701d General Hardware/Equipment Discussion 13 08-01-2010 11:35 AM
Turboflotor 1000 multi Skimmer $175 jrp1588 Archive 0 02-05-2010 04:00 PM
Turboflotor Blue 1000 spikey General Hardware/Equipment Discussion 0 08-17-2009 09:15 AM
Aqua Medic Turboflotor 1000 Multi SL Skimmer Problem Reefer27 General Hardware/Equipment Discussion 1 03-17-2009 02:56 AM
Aqua C Urchin Pro vs Turboflotor 1000 vs ASM G-1 mardeebo General Hardware/Equipment Discussion 2 05-25-2005 03:40 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 05:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.