Go Back   Aquarium Advice - Aquarium Forum Community > Freshwater > Freshwater & Brackish - General Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 04-15-2015, 11:39 PM   #1
Aquarium Advice Addict
 
Toad's Avatar
 
Join Date: Jun 2013
Posts: 1,204
Found out why my filter wasn't running right...

Handfuls of sand. Got it running nice again thank god but I'm very annoyed with myself for not realizing what was happeningClick image for larger version

Name:	ImageUploadedByAquarium Advice1429151931.487644.jpg
Views:	61
Size:	159.5 KB
ID:	270150
__________________
Toad is offline   Reply With Quote
Reply

Tags
filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MTS - and I wasn't even trying !!!! joannde Freshwater & Brackish - General Discussion 6 06-12-2006 11:38 AM
Well, I sure wasn't expecting this either, Part II. Devilishturtles Freshwater & Brackish - Breeding 18 05-24-2006 09:29 PM
Well, I sure wasn't expecting this... Devilishturtles Freshwater & Brackish - Breeding 21 05-19-2006 02:30 PM
If $ wasn't an issue/which (lighting setup) would you choose JamesR Nano Reefs 4 01-27-2005 12:41 AM







» Photo Contest Winners







All times are GMT -4. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×