Go Back   Aquarium Advice - Aquarium Forum Community > Freshwater > Freshwater & Brackish - General Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 05-04-2006, 04:16 PM   #1
Aquarium Advice FINatic
 
Join Date: Jan 2005
Location: Cambridge, England (UK)
Posts: 610
Prime

I use Prime as a dechlorinator and it seems to do the job very well and is fairly cheap.

However i have noticed that it seems to smell, pretty bad a week after using or opening the bottle. Is this normal? The smell is pretty bad ad dosent get any better.
__________________

__________________
20Gal Planted, Fluval 205 filtration.
3 Black Neons, 1 Zebra Danio, 1 Clown Pleco, 3 Yo-yo Loaches.
Tank Established: Nov 04'
Satsumas is offline   Reply With Quote
Old 05-04-2006, 04:34 PM   #2
AA Team Emeritus
 
An t-iasg's Avatar


 
Join Date: Aug 2003
Location: Criders Corners, PA
Posts: 9,889
Yes, Prime does have a strong odor. I have had my bottle for about a month now. When it was first new, it did smell but not too bad. Now, it's bad, lol. I hold my breath when dispensing it! The water itself holds none of the odor and the tanks don't smell like the Prime smell. I notice little black "spots" in my bottle also. The Seachem website says that is also normal.
__________________

__________________







An t-iasg is offline   Reply With Quote
Old 05-04-2006, 04:36 PM   #3
kaz
Aquarium Advice Addict
 
Join Date: Sep 2005
Location: Los Angeles
Posts: 1,292
perfectly normal shake well before each use and it contains and develops small black grains.
__________________
I thank you all for your attention and time!
75g/Rena Xp3/Inline Heater/Rena Air 200/Eco-Complete/Current Dual Daylight System
6 Rummy Nose, 9 Ottos, 2 Yoyo Loach, 1 Golden Nugget Pleco, 2 Julli's Cory, 4 Angelicus Botia, 1 Chocolate Kuhli Loach, 3 Ghost Shrimp, 1 SAE, 1 Black Mollie, 1 Redeye Swordtail Mollie, 1 C-Pleco, MTS, Guppy's
Plants
Argentine Sword, Amazon Sword, Micro Sword, Xmas Moss, Pennywort, Hornwort, Jave Fern, Baby Tears, Moneywort, Ludwigia, Wisteria, Giant Bacoba, Hygro 'Sunset'
kaz is offline   Reply With Quote
Old 05-04-2006, 05:02 PM   #4
Aquarium Advice FINatic
 
Join Date: Jan 2005
Location: Cambridge, England (UK)
Posts: 610
Yeah i thought it was normal, i did smell the fresh tap water after adding prime and couldnt really smell anything so i carried on using it.
__________________
20Gal Planted, Fluval 205 filtration.
3 Black Neons, 1 Zebra Danio, 1 Clown Pleco, 3 Yo-yo Loaches.
Tank Established: Nov 04'
Satsumas is offline   Reply With Quote
Reply

Tags
prime, rim

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using prime ? InfernoST Saltwater Fish Only & FOWLR 10 08-28-2009 03:17 AM
Too much Prime? severum mama Freshwater & Brackish - General Discussion 11 12-13-2006 11:36 PM
PRIME Brian Vartanian Saltwater Reef Aquaria 8 11-18-2005 09:47 AM
Prime aquazen Freshwater & Brackish - Unhealthy Fish 12 09-29-2004 11:50 PM
Seachem Prime cdawson Freshwater & Brackish - General Discussion 18 07-16-2003 01:31 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 01:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.