Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater & Reef - Getting Started
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-20-2013, 08:20 PM   #1
Aquarium Advice FINatic
 
sansouci01's Avatar
 
Join Date: Jul 2012
Location: Orlando Florida
Posts: 708
Anything I can do ???

I know this subject has been addressed a million times but I want to make sure that I'm not doing anything wrong. My 20 gallon tank has been up and running for about two months now. All my water parameters are at 0ppm. I do weekly water changes but my diatom problem seems to be not getting any better. I know it takes time but is there anything else I can do to help. My 55 gallon freshwater tank went through the same thing but it only lasted about a month..
Attached Thumbnails
Click image for larger version

Name:	tank 030.jpg
Views:	52
Size:	245.5 KB
ID:	208546   Click image for larger version

Name:	tank 032.jpg
Views:	54
Size:	215.8 KB
ID:	208547  

__________________

__________________
sansouci01 is offline   Reply With Quote
Old 11-20-2013, 08:39 PM   #2
Aquarium Advice Addict
 
bribo12's Avatar

Tank of the Month Award
 
Join Date: Sep 2013
Location: Maryland
Posts: 9,117
Your tank is still pretty young. Mine went through different algae phases for the first 5 months before it hit a point where all the algae went away. Are you using ro/di? That doesn't look like diatoms but more some type of cyano. Try to increase flow and add some phosphate remover. When you do wc suck it out as well.
__________________

__________________
20 Gallon SPS reef
29 Gallon FW "fat catfish" tank
20 Gallon Long Dart Frogs "Zig" and "Zag"
bribo12 is offline   Reply With Quote
Old 11-20-2013, 08:41 PM   #3
Aquarium Advice Addict
 
huma-huma's Avatar

POTM Champion
 
Join Date: May 2011
Location: washington Pa
Posts: 5,257
yeah id look at flowrate first. id say you dont have enough flow in the tank so its running rampant in your tank
__________________
my 125g Sw...Round 2!http://www.aquariumadvice.com/forums...220171-33.html
ever see someone cut a 125g in half??
http://www.aquariumadvice.com/forums...-286438-4.html
huma-huma is offline   Reply With Quote
Old 11-20-2013, 08:46 PM   #4
Aquarium Advice FINatic
 
sansouci01's Avatar
 
Join Date: Jul 2012
Location: Orlando Florida
Posts: 708
I do use ro/di water. I have two powerheads. One is koralia 240 and the other is a koralia 425. Do I need more flow than that ?
__________________
sansouci01 is offline   Reply With Quote
Old 11-20-2013, 08:49 PM   #5
Aquarium Advice Addict
 
bribo12's Avatar

Tank of the Month Award
 
Join Date: Sep 2013
Location: Maryland
Posts: 9,117
Quote:
Originally Posted by sansouci01 View Post
I do use ro/di water. I have two powerheads. One is koralia 240 and the other is a koralia 425. Do I need more flow than that ?
I have the same powerheads in my 20. Hmm
__________________
20 Gallon SPS reef
29 Gallon FW "fat catfish" tank
20 Gallon Long Dart Frogs "Zig" and "Zag"
bribo12 is offline   Reply With Quote
Old 11-20-2013, 08:53 PM   #6
Aquarium Advice Addict
 
huma-huma's Avatar

POTM Champion
 
Join Date: May 2011
Location: washington Pa
Posts: 5,257
youre just over 33x turnover so id say you are good. just try aiming the powerheads in different directions. remember to give them a few days to see what happens
__________________
my 125g Sw...Round 2!http://www.aquariumadvice.com/forums...220171-33.html
ever see someone cut a 125g in half??
http://www.aquariumadvice.com/forums...-286438-4.html
huma-huma is offline   Reply With Quote
Old 11-20-2013, 09:32 PM   #7
Aquarium Advice FINatic
 
sansouci01's Avatar
 
Join Date: Jul 2012
Location: Orlando Florida
Posts: 708
I have one on each side of the tank. One pointed toward the back glass and the other toward the front glass. Should I point them differently ?
__________________
sansouci01 is offline   Reply With Quote
Old 11-22-2013, 12:46 PM   #8
Aquarium Advice Addict
 
huma-huma's Avatar

POTM Champion
 
Join Date: May 2011
Location: washington Pa
Posts: 5,257
Yeah. Just try experimenting with them until you find a decent setup that slows the algae growth
__________________

__________________
my 125g Sw...Round 2!http://www.aquariumadvice.com/forums...220171-33.html
ever see someone cut a 125g in half??
http://www.aquariumadvice.com/forums...-286438-4.html
huma-huma is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 08:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.