Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater & Reef - Getting Started
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 07-21-2009, 03:32 PM   #1
Aquarium Advice Apprentice
 
Join Date: Jul 2009
Posts: 11
help, advice needed setting up a fluval venezia tank?

i have the cabinet built and the tank in place, now its connecting the filter system and pipes to the tank....worried about things not being fitted correct and water spillage when the tank is filled!!
__________________

__________________
kaykay is offline   Reply With Quote
Old 07-21-2009, 03:35 PM   #2
Aquarium Advice Addict
 
partypalooza5's Avatar
 
Join Date: Mar 2009
Location: Texas
Posts: 1,274
Send a message via AIM to partypalooza5 Send a message via Yahoo to partypalooza5
If its a hose to barb connection, just make sure its pushed on there snugly, for threaded make sure its snug too. There are only two hoses and 4 connections (If it's the model I'm thinking of.) Good luck!
__________________

__________________
75G FOWLR Build

partypalooza5 is offline   Reply With Quote
Old 07-21-2009, 03:38 PM   #3
Aquarium Advice Apprentice
 
Join Date: Jul 2009
Posts: 11
and when the manual says fill the tank half way and switch the filter on to test it...but the pipes which come out of the filter into the tank are quite tall...so would the water have to cover these for the filter to work?
__________________
kaykay is offline   Reply With Quote
Old 07-21-2009, 03:50 PM   #4
Aquarium Advice Activist
 
Join Date: May 2009
Posts: 122
Your intake height should be well below half way. That's all that matters, that the intake be submerged
__________________
CementShoes is offline   Reply With Quote
Old 07-21-2009, 03:50 PM   #5
Aquarium Advice Addict
 
partypalooza5's Avatar
 
Join Date: Mar 2009
Location: Texas
Posts: 1,274
Send a message via AIM to partypalooza5 Send a message via Yahoo to partypalooza5
The tank meaning the aquarium or the filter tank? The intake pipe has to be submerged in order for the filter to work.

I'm not sure if this helps but here's what I would do to set it up:

1) put media in the filter
2) put water in the filter tank
3) put the lid on
4) attach the hoses
5) prime the pump (if possible on your model of filter)
6) plug it in
__________________
75G FOWLR Build

partypalooza5 is offline   Reply With Quote
Old 07-21-2009, 03:53 PM   #6
Aquarium Advice Activist
 
Join Date: May 2009
Posts: 122
I would not worry about it being saltwater at this point either. They are just having you check the pump and connections before you get too far along.
__________________
CementShoes is offline   Reply With Quote
Old 07-21-2009, 03:54 PM   #7
Aquarium Advice Apprentice
 
Join Date: Jul 2009
Posts: 11
has anyone ever had problems with tanks leaking? my dad has told me if any damage occurs ive got to pay for it etc....now im worried
__________________
kaykay is offline   Reply With Quote
Old 07-21-2009, 03:57 PM   #8
Aquarium Advice Activist
 
Join Date: May 2009
Posts: 122
Never had one but I assume the bulkheads (the connections that span the hose from in tank to outside the tank) came pre-installed. If that's the case then other then some minor connections leaks it should be pretty str8 forward.

At most, over time, you may get some drips that require attention but full scale failure is unlikely.

What size?
__________________
CementShoes is offline   Reply With Quote
Old 07-21-2009, 04:01 PM   #9
Aquarium Advice Apprentice
 
Join Date: Jul 2009
Posts: 11
its a 190litre tank, and its in my bedroom upstairs, im picturing leaks and the floor falling through! yeah the main connections were installed already, its just a matter of connecting the piping.
__________________
kaykay is offline   Reply With Quote
Old 07-21-2009, 04:02 PM   #10
Aquarium Advice Activist
 
Join Date: May 2009
Posts: 122
Just checked the install manual. The are quick connects so you shouldn't have any problems with the connections.
__________________

__________________
CementShoes is offline   Reply With Quote
Reply

Tags
fluval, setting up, tan, val

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up planted Tank.... Help Needed rohitp78 Freshwater & Brackish - Planted Tanks 17 07-25-2006 03:17 PM
Setting up a 10 Gallon- Advice Needed! Renn Freshwater & Brackish - General Discussion 5 06-15-2006 08:45 PM
setting up a new planted tank, advice needed Scottm Freshwater & Brackish - Planted Tanks 13 08-24-2005 10:57 PM
Setting up a 55 Gallon, some advice needed. crew_dawg16 Freshwater & Brackish - Getting Started 15 08-18-2005 12:30 AM
Need advice setting up FO tank! Rod18844 Saltwater & Reef - Getting Started 2 11-27-2003 01:21 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 08:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.