Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater & Reef - Getting Started

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 06-27-2006, 07:14 AM   #1
Aquarium Advice Activist
Join Date: Jan 2006
Location: Newjersey
Posts: 106
Is my skimmer working?

I see that the bubbles are being created. It also pushes some foam to the top of the collecting cup. However the foam is very clear and it does not extract waste as it used to be. A thin layer of brown sediment is also forming on my substrate once every two days. From the bubbles creation the skimmer seems to be working fine. But is there a blockage or something that makes skimmer not to collect waster? How do I ensure that the skimmer is working? This is four months old Won brothers skimmer.
Attached Images
File Type: jpg img_2771_3_106.jpg (18.8 KB, 124 views)

aravindk is offline   Reply With Quote
Old 06-27-2006, 08:13 AM   #2
SW 20 & Over Club
ccCapt's Avatar

Join Date: Mar 2004
Location: Northeast PA
Posts: 5,362
Send a message via ICQ to ccCapt
Still looks to me like you have no where near enough air being injected. The water should be milky white with bubbles. The DOC's stick to the bubbles which is what produces the "dirt". Very few bubbles = very little dirt.

125g reef
See My Tank Info
Check out The build project
ccCapt is offline   Reply With Quote
Old 06-27-2006, 09:24 AM   #3
Aquarium Advice Activist
Join Date: Jan 2006
Location: Newjersey
Posts: 106
I took it apart and cleaned it. it didnt help I guess. How long does a skimmer last? The mechanism within the skimmer is simple (IMO) with no moving parts or anything, I would expect my skimmer last longer than 4 months. Is this a sign that the skimmer broke and I should look for replacing it or is there something that I can make it work again?

The DOC's are pumped in by the powerhead right? Could there be some blockage in the powerhead that is not pushing enough DOC's? If that is the case I must replace the powerhead not the skimmer???

Thanks for trying to help me out...
aravindk is offline   Reply With Quote
Old 06-28-2006, 12:48 AM   #4
Aquarium Advice Activist
Join Date: Sep 2004
Location: McKinney, TX
Posts: 140
I've never had a skimmer body wear out. They can get clogged with debris or snails and o-rings fail after a time. Clean the body and check your pump for sure. Pull it apart and make sure it's clean inside. You can use vinegar to dissolve the white deposits if you find any on the impeller. Rinse it good afterwards.
I had a Mag3 pump give up after almost 4 years of constant running. I replaced it with a new Mag3 and I couldn't belive the difference in the amount of crud pushed into the collection cup. My old pump had been slowly dieing and I didn't notice it.
Steve - DFWMAS
92-gal Corner Bowfront: VHOs,PCs,LR,LS,Sump,Skimmer,Fish,Soft Corals,LPS (Born again 9-04)

29-gal: PCs,LR,LS,Skimmer,Fish,Soft corals (Born 9-04)
No_Floaters is offline   Reply With Quote
Old 06-28-2006, 02:11 AM   #5
Aquarium Advice Freak
dscount's Avatar
Join Date: Dec 2005
Location: Alaska
Posts: 249
Send a message via MSN to dscount Send a message via Yahoo to dscount
you have an air valve or something that can be adjusted on the pump? I've a Berlin that has two items to adjust (Flow and Air Flow via tube w/screw for amount).

Usually playing with either will create more or less bubbles. You need the "FINE" bubbles to get everything.

You are getting foam, but it's not exactly what you want.
75gal Salt, 18gal Sump, Skimmer, 60lb Live Rock, 90lb Live Sand, 3 Pwrhd, 2x55w Actinic, 2x55w 10k. Guest list: Goby Green Clown, Percula Clown and entire clean up crew.
dscount is offline   Reply With Quote


Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Protein skimmer not working. ThAtGuY11 Saltwater Reef Aquaria 3 11-15-2007 06:00 PM
Skimmer not working two11devan General Hardware/Equipment Discussion 7 10-13-2007 04:56 PM
New Skimmer Still not working? blazeyreef General Hardware/Equipment Discussion 12 05-17-2007 12:54 PM
skimmer not working Lindsikins00 Saltwater Reef Aquaria 3 08-06-2004 09:48 AM
new skimmer not working sillyfishy Saltwater Reef Aquaria 6 04-25-2004 01:33 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 12:10 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.