Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater & Reef - Getting Started
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 07-31-2003, 02:41 AM   #1
Aquarium Advice Apprentice
 
Join Date: Jul 2003
Location: Chicago, IL
Posts: 22
Send a message via AIM to Munskins
WetDry Problem, Please Help ASAP!

I was doing a water change and forgot to turn off the wet dry . When I looked at the head (the thing that spits out the water), it was spitting water like h+ll broke loose!

I filled it back up to where the glass ends and turned the switch back on and nothing. The protein skimmer and the UV Light was still working but the pump didnt seem to be pushing or making any noise.

Did I just brake the pump or is there anything else that I have done wrong?

Other Facts: The water in the wet dry is way pass the water level line so I may have put too much water in. There is no water in the tubing that goes back to the tank (from the pump).
__________________

__________________
Munskins is offline   Reply With Quote
Old 07-31-2003, 07:02 AM   #2
AA Team Emeritus
 
reefrunner69's Avatar
 
Join Date: May 2002
Location: Cedar Key, FL
Posts: 1,663
What kind of pump is it?

It is possible that running it dry has overheated it and it needs to cool down. It is also possible that running it dry has burned it up. It may need to be primed, depending. Need more info to help out
__________________

__________________
Kevin

Visit Nature Coast Photography
reefrunner69 is offline   Reply With Quote
Old 07-31-2003, 07:15 PM   #3
Aquarium Advice Apprentice
 
Join Date: Jul 2003
Location: Chicago, IL
Posts: 22
Send a message via AIM to Munskins
It is a RIO 3100. Its been cooling down in the water for awhile, so I guess it burned . Never heard of priming, tell me more...give me hope . Thanks.

Also, is there suppose to be water in the tubing that goes from the pump back to the tank?
__________________
Munskins is offline   Reply With Quote
Old 07-31-2003, 08:37 PM   #4
AA Team Emeritus
 
Join Date: May 2002
Location: Virginia
Posts: 2,256
Send a message via ICQ to fishfreek Send a message via AIM to fishfreek Send a message via MSN to fishfreek Send a message via Yahoo to fishfreek
the tube from the pump to the tank will be empty when you power the pump off. if the pump is submerged then you sould not have to prime it. If it was an external pump then priming might be required.

when you plug the pump in do you hear anything? if you wiggle the pump around any while plugged in does it start?

Since its a RIO you might have to take the pump apart and clean the impeller and the shaft as they can sometimes get some gunk bult up on them.

Rios overall have bad rep for not restarting.
__________________
Remember dont tap the glass, your fish will think you're an idiot -Anonymous mother

Check out our articles area. 30+ Aquatic articles for your enjoyment
Are you in or around the Shenandoah Valley area? If so click here to join our regional forum.
fishfreek is offline   Reply With Quote
Old 07-31-2003, 08:46 PM   #5
AA Team Emeritus
 
reefrunner69's Avatar
 
Join Date: May 2002
Location: Cedar Key, FL
Posts: 1,663
Smell it, if it smell burned, it's toast.
__________________
Kevin

Visit Nature Coast Photography
reefrunner69 is offline   Reply With Quote
Old 07-31-2003, 09:08 PM   #6
Aquarium Advice Apprentice
 
Join Date: Jul 2003
Location: Fair Oaks, CA
Posts: 14
With a Rio it was just a matter of time.
__________________
Beerman is offline   Reply With Quote
Old 07-31-2003, 09:21 PM   #7
Aquarium Advice FINatic
 
Join Date: Jul 2003
Location: Dallas, TX, USA
Posts: 507
Send a message via ICQ to Gauge Send a message via Yahoo to Gauge
If RIos suck, then what's a good, powerful pump to use for getting water from your sump to your tank?
__________________
- Gauge

92-gallon corner tank, 100lbs of LR, 140lbs of sand, 250watt 10,000K MH, 110watts of actinic PCs, Mag 7 return, custom refugium, AquaC EV180 w/ Mag 5

Female lyretail anthias, eyelash blenny, tomato clown, saddleback clown, firefish goby, 2 sand-sifting stars
Gauge is offline   Reply With Quote
Old 07-31-2003, 09:26 PM   #8
AA Team Emeritus
 
reefrunner69's Avatar
 
Join Date: May 2002
Location: Cedar Key, FL
Posts: 1,663
I like Mag Drive submerssible pumps. For external I like Iwakis or Lil Giants.
__________________
Kevin

Visit Nature Coast Photography
reefrunner69 is offline   Reply With Quote
Old 07-31-2003, 10:13 PM   #9
Aquarium Advice Apprentice
 
Join Date: Jul 2003
Location: Chicago, IL
Posts: 22
Send a message via AIM to Munskins
Whats the word on Quiet One Pumps, better than Rio I hope?
__________________
Munskins is offline   Reply With Quote
Old 07-31-2003, 10:16 PM   #10
AA Team Emeritus
 
reefrunner69's Avatar
 
Join Date: May 2002
Location: Cedar Key, FL
Posts: 1,663
Quiet ones are decent pumps, when I had experience with them they only came in one size. If I'm not mistaken (which is entirely possible) they are owned by Mag Drive and hopefully held to the same standards.
__________________

__________________
Kevin

Visit Nature Coast Photography
reefrunner69 is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Problem pls HELP asap mike3epanda Saltwater Fish Only & FOWLR 19 10-10-2007 03:49 PM
Junk in WetDry GatorDrew Saltwater Fish Only & FOWLR 1 05-27-2006 03:38 PM
[from Gen. forums] Crazy algae problem! (please help ASAP) cgcaver Freshwater & Brackish - Planted Tanks 3 04-29-2005 10:45 AM
Crazy algae problem! (please help ASAP) cgcaver Freshwater & Brackish - Planted Tanks 14 04-28-2005 12:31 PM
Guppy Fin problem ASAP! jessiejohnson Freshwater & Brackish - Unhealthy Fish 1 04-27-2004 02:13 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 02:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.