Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater & Reef - Sick Fish or Coral
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-20-2011, 07:09 PM   #1
member
 
Join Date: May 2011
Posts: 2
Algea bloom and do I need a UV

I been having this problem for a month now . The guy at the fish store said it was an algae bloom and u should buy a better uv sterilizer. I did and two works later I need to keep cleaning every two days if not it gets like this .. any recommendations in what I should do.
Attached Thumbnails
Click image for larger version

Name:	ForumRunner_20110620_150458.jpg
Views:	179
Size:	29.4 KB
ID:	41095  
__________________

__________________
ang3lwtf is offline   Reply With Quote
Old 06-20-2011, 07:14 PM   #2
SW REEF 18+ YEARS
Community Admin
 
melosu58's Avatar



Tank of the Month Award
 
Join Date: Oct 2004
Location: Virginia
Posts: 38,244
My tank is over 13 yrs old and I have to run the mag float over the glass every 3 days. You wont ever get over that. What are your water test results?
__________________

__________________

SITE ADMINISTRATOR

You can view many of my fish and corals in my photo albums in my profile.

View my tank


AA Community Rules|AA TOS

Forums 101 - posting, accounts, basics
melosu58 is offline   Reply With Quote
Old 06-20-2011, 07:34 PM   #3
Aquarium Advice Freak
 
Join Date: May 2011
Location: South shore Nova Scotia
Posts: 420
Isn't a bloom free floating algae? That looks on the glass , which would be light or water quality, had tanks around the house for 25 years, never really even seen algae before just slight film that's invisible or the odd gear near the lights, I wonder if it would be bad starting water screwing you over
__________________
dollabill420 is offline   Reply With Quote
Old 06-20-2011, 08:14 PM   #4
Thanx but no.....


 
Join Date: Jun 2008
Posts: 2,333
Scrub the glass. Get used to it, it's a weekly (at best) thing
__________________
*
If I wanted someone to 'tag along' I'd buy a wagon.

I despise skinny felines!
CaptainAhab is offline   Reply With Quote
Old 06-26-2011, 11:27 PM   #5
Aquarium Advice Freak
 
Join Date: May 2011
Location: South shore Nova Scotia
Posts: 420
Quote:
Originally Posted by CaptainAhab
Scrub the glass. Get used to it, it's a weekly (at best) thing
I fell even luckier now lol have an algae magnet and used it about 8 years ago lol
__________________
dollabill420 is offline   Reply With Quote
Old 06-29-2011, 05:43 AM   #6
Aquarium Advice FINatic
 
Join Date: Feb 2011
Posts: 681
Maybe clean your skimmer, change lights, or you might have sun hitting the tank.
__________________

__________________
Codyheitmiller is offline   Reply With Quote
Reply

Tags
algea, bloom

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.