Go Back   Aquarium Advice - Aquarium Forum Community > Saltwater and Reef > Saltwater & Reef - Sick Fish or Coral
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-23-2011, 09:25 PM   #1
Aquarium Advice Regular
 
Join Date: May 2011
Location: Long Island
Posts: 54
Blasto problem

What's going on here with my blasto. Have it for about a month now. Always doing well, very hardy. About 5 hours ago I got two nice mysis shrimp to stick to him and swallowed it in no time. Now its got the mark that looks like a pinch. Of coarse first thought was a fish nipped it. I find it highly unlikely in my tank. From my understand they don't split. Soooo any suggestions?
Attached Thumbnails
Click image for larger version

Name:	image-241398406.jpg
Views:	35
Size:	59.2 KB
ID:	62668   Click image for larger version

Name:	image-700072685.jpg
Views:	43
Size:	61.9 KB
ID:	62669  

__________________

__________________
shamrock13 is offline   Reply With Quote
Old 11-25-2011, 11:22 PM   #2
Aquarium Advice Addict
 
crister13's Avatar
 
Join Date: Aug 2011
Location: Princeton, NJ
Posts: 3,473
Didnt you already post this? Please dont repost the same question. You already got a good answer. Its fine.
__________________
crister13 is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BIG problem!! Help GREATLY appreciated! rammin88 Freshwater & Brackish - General Discussion 7 10-18-2011 09:28 PM
AquaClear HOB filter leaking - anyone else have this problem? hbeth82 General Hardware/Equipment Discussion 2 10-03-2011 02:20 PM
Aqueon Pro 50 Watt heater problem! Help please! Stef Freshwater & Brackish - Getting Started 5 09-11-2011 01:24 AM
weird fishless cycling problem ben27 Freshwater & Brackish - Getting Started 7 08-24-2011 08:21 PM
Weird nitrite problem nibynool Freshwater & Brackish - Planted Tanks 2 07-28-2011 10:39 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 04:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.