Go Back   Aquarium Advice - Aquarium Forum Community > Community Forum > Aquaria Off-Topic
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 09-14-2011, 11:56 PM   #1
Aquarium Advice Addict
 
Gboy66's Avatar

POTM Champion
 
Join Date: Aug 2011
Location: Cali baby
Posts: 6,826
Filter is messed up!!!!

Have a penguin biowheel, and the thing juat wont work for some reason!!!! It was on and working, we started pouring in eco complete gravel, then we noticed later that it wouldnt work even if plugged in. Must be the intake valve because water wont even fill the filter...please help!!!!
__________________

__________________
Gboy66 is offline   Reply With Quote
Old 09-15-2011, 12:02 AM   #2
Aquarium Advice FINatic
 
picture_117's Avatar
 
Join Date: Jan 2011
Location: Fort Worth, Texas
Posts: 734
I have the same one, not the best filters.

My biowheel spins like the first week and then stops. The intake builds up gunk, and the filter media/cartridges can be built up with gunk not allowing enough water through at a time spinning the wheel.
Clean your intake and filter cartridges if they're dirty, that should fix it, its always the problem in mine.
__________________

__________________
picture_117 is offline   Reply With Quote
Old 09-15-2011, 12:05 AM   #3
Aquarium Advice Addict
 
Gboy66's Avatar

POTM Champion
 
Join Date: Aug 2011
Location: Cali baby
Posts: 6,826
Ok whew can the intake separate into 2 pieces so i can have a look inside? Also does it have a propeller inside or no?
__________________
Gboy66 is offline   Reply With Quote
Old 09-15-2011, 12:06 AM   #4
Aquarium Advice FINatic
 
picture_117's Avatar
 
Join Date: Jan 2011
Location: Fort Worth, Texas
Posts: 734
Yes it should, mine does.
And there is a propeller inside.
Is eco complete sandy? I'm not familiar with that substrate.

Edit: just read it says gravel -_- lol.
I have sand in my tank and that got into the propeller not allowing it to spin fully. But with your gravel it shouldn't be a problem.
__________________
picture_117 is offline   Reply With Quote
Old 09-15-2011, 12:16 AM   #5
Aquarium Advice Addict
 
Gboy66's Avatar

POTM Champion
 
Join Date: Aug 2011
Location: Cali baby
Posts: 6,826
Should have a look at the propellor? Because all the tubes were clean and my cartridge was too! Im stumped
__________________
Gboy66 is offline   Reply With Quote
Old 09-15-2011, 12:19 AM   #6
Aquarium Advice FINatic
 
picture_117's Avatar
 
Join Date: Jan 2011
Location: Fort Worth, Texas
Posts: 734
You can, just make sure it spins smoothly.

So what exactly is the problem? Biowheel is not spinning or the filter doesn't take in enough water.
__________________
picture_117 is offline   Reply With Quote
Old 09-15-2011, 12:24 AM   #7
Aquarium Advice Addict
 
Gboy66's Avatar

POTM Champion
 
Join Date: Aug 2011
Location: Cali baby
Posts: 6,826
I plug it in and it wont even suck up water! And ya this is weird
__________________
Gboy66 is offline   Reply With Quote
Old 09-15-2011, 12:27 AM   #8
Aquarium Advice FINatic
 
picture_117's Avatar
 
Join Date: Jan 2011
Location: Fort Worth, Texas
Posts: 734
Hm, is the filter box full of water?

When you plug in the filter make sure the box is full of water
__________________
picture_117 is offline   Reply With Quote
Old 09-15-2011, 01:18 AM   #9
Aquarium Advice Addict
 
Gboy66's Avatar

POTM Champion
 
Join Date: Aug 2011
Location: Cali baby
Posts: 6,826
Yes then it overflows, but that water isnt enough to turn the wheel
__________________
Gboy66 is offline   Reply With Quote
Old 09-15-2011, 01:38 AM   #10
Aquarium Advice FINatic
 
picture_117's Avatar
 
Join Date: Jan 2011
Location: Fort Worth, Texas
Posts: 734
That really is weird.
It was working fine before?
__________________

__________________
picture_117 is offline   Reply With Quote
Reply

Tags
filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
need filter advice for 29 gallon ashleynicole Freshwater & Brackish - Getting Started 9 09-14-2011 01:48 AM
How to fast cycle with an API NEXX filter (or any filter)) zparticle Freshwater & Brackish - Getting Started 8 09-11-2011 09:36 AM
Using Filter Media from aquaone in a juwel filter. bjtaylor Freshwater & Brackish - Getting Started 0 07-31-2011 07:00 AM
How long to seed new media? mikeybabs Cichlid Discussion 5 07-10-2011 11:12 PM
Ati hydro sponge filter Ant329 General Hardware/Equipment Discussion 2 07-06-2011 12:57 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 06:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.