Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 08-04-2009, 11:08 PM   #1
Aquarium Advice Freak
 
Frogspawn's Avatar
 
Join Date: Feb 2007
Location: Falling Waters WV
Posts: 486
AquaC EV-120

Good Evening,

I have a few Questions on my AquaC EV-120. I purchased My skimmer about 3 months ago when i first set my 30g SW Aquarium up. I have tinkered with this skimmer for months and have not been able to get it to produce any foam. It did not come with a water pump but recommended a mag5. I bought a Mag5 and a Mag7 for my water movement though my aquarium. i choose these two pumps because i read some where online that some people got better results using a higher flow rate though the Ev120. I started out using the Mag5 like recommended and found out quickly it was not producing any foam. for this set up i had the air valve completely open and played with the gate valve over the next 2 months to find the correct setting, Nothing seemed to work. So, i figured trying to use the Mag7 and now all i get is extreme water aeration inside the skimmer which is producing alot of Water foam, if that makes sense. The collection cup fills with water in minutes and thats with the air completely restricted and the gate valve on the skimmer open 100%. I have read the manual and followed the directions to a "T" but this has become a very stressful experience dialing this skimmer in. I hear its a great skimmer so i am motivated to get this unit working.

I do have a few ideas to why this unit is not producing any foam.

1. There not enough protein in the aquarium to skim out even though i though by feeding every day i would see at-least something by now.

2. I do have quite abit of hair algae i am combating. so, that might be eating up the excessive Nutrients my skimmer would be cleaning.

3. i only have 2 fish so the water changes i perform every few weeks might clean the tank leaving no protein to skim.

Its important to me to get this unit running because i feel it would help me fight this hair algae issues i have been having for quite some time now.

any help from people with Ev120s would be great!
__________________

__________________
Frogspawn
If it was not for mistakes we would never get better.
Frogspawn is offline   Reply With Quote
Old 08-06-2009, 07:12 PM   #2
Aquarium Advice Freak
 
Frogspawn's Avatar
 
Join Date: Feb 2007
Location: Falling Waters WV
Posts: 486
Any ideas what i should do to get this Skimmer running better?
__________________
Frogspawn
If it was not for mistakes we would never get better.
Frogspawn is offline   Reply With Quote
Reply

Tags
aquac

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WANTED: Proquatics 120/ Hydor Bravo 120 HOB filter part clearerphish Archive 0 06-02-2007 09:05 PM
aquac remora dngonzales General Hardware/Equipment Discussion 2 06-02-2005 10:54 AM
anyone with a AquaC Urchin .. ? kukki Saltwater Reef Aquaria 9 05-25-2005 10:43 AM
AquaC Urchin Pro VS. EV-120 nyghtone Saltwater Reef Aquaria 4 09-01-2004 07:30 PM
AquaC Ev-120 series question Brisc0 General Hardware/Equipment Discussion 1 02-29-2004 03:57 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 05:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.