Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 04-19-2011, 11:35 PM   #11
Aquarium Advice Apprentice
 
Join Date: Feb 2011
Posts: 31
Well, like I said, I cleaned it all out and put it back together. There were a couple of small stones or something in with the impeller shaft. How can I tell if it's filtering properly now, without pulling it off the tank and looking at the sponge again?

Thanks for all your help guys. 
__________________

__________________
RugbyBunny is offline   Reply With Quote
Old 04-20-2011, 06:36 PM   #12
Aquarium Advice Addict
 
BigJim's Avatar
 
Join Date: Jul 2009
Location: Oak Forest, IL
Posts: 4,388
If the filter is working properly, you should see a steady flow returning to the tank, hear no noise other than maybe a hum, and see the tank getting clearer.
__________________

__________________
A man's errors are his portals of discovery.
Guide to The Fishless Cycle Cycling With Fish
My DIY LED Light Fixture
Feel free to PM me directly with questions.
BigJim is offline   Reply With Quote
Old 04-20-2011, 08:52 PM   #13
Aquarium Advice Apprentice
 
Join Date: Feb 2011
Posts: 31
Ok... I've always seen a steady return to the tank. So, I'm not too sure of it's really working and filtering properly or what. Any thoughts?
__________________
RugbyBunny is offline   Reply With Quote
Old 04-21-2011, 07:44 PM   #14
Aquarium Advice Addict
 
BigJim's Avatar
 
Join Date: Jul 2009
Location: Oak Forest, IL
Posts: 4,388
When was the last time you cleaned the filter? I usually clean my ACs about once a month.
__________________
A man's errors are his portals of discovery.
Guide to The Fishless Cycle Cycling With Fish
My DIY LED Light Fixture
Feel free to PM me directly with questions.
BigJim is offline   Reply With Quote
Old 04-21-2011, 08:11 PM   #15
Aquarium Advice Apprentice
 
Join Date: Feb 2011
Posts: 31
2 or 3 days ago
__________________
RugbyBunny is offline   Reply With Quote
Old 04-21-2011, 08:56 PM   #16
Aquarium Advice Addict
 
BigJim's Avatar
 
Join Date: Jul 2009
Location: Oak Forest, IL
Posts: 4,388
If you've got the filter assembled correctly, the plumbing and media aren't gunked up, and you've got the flow adjustment set to the max, I'd say the filter is working. One of the benefits of the ACs is the huge media capacity. I've got two 8"+ catfish, some rams, some rainbows, rasboras, and a betta in a 40B with an AC110. The sponge has yet to get very dirty. I usually feel like I'm wasting my time when I clean it, but the filter keeps the tank spotless.
__________________
A man's errors are his portals of discovery.
Guide to The Fishless Cycle Cycling With Fish
My DIY LED Light Fixture
Feel free to PM me directly with questions.
BigJim is offline   Reply With Quote
Old 04-22-2011, 04:49 PM   #17
Aquarium Advice Apprentice
 
Join Date: Feb 2011
Posts: 31
Wow. That's crazy. This filter has had issues keeping the tank water clear. I'm not sure if it's due to the dirtiness of the filter or what. Do you have the ammonia rocks in your filter too or just the carbon and sponge? I was at the LFS yesterday and saw that there is a combo of carbon and ammonia filter. Any thoughts on that media?

And now the filter is going to have to work twice as hard... Mu daughter decided to feed the fish this am and dumped about 95% of the bottle into the tank. I got as much as I could with a PWC but it's still pretty cloudy. Any suggestions?
__________________
RugbyBunny is offline   Reply With Quote
Old 04-23-2011, 02:36 AM   #18
Aquarium Advice Apprentice
 
Join Date: Feb 2011
Posts: 31
I syphoned as much of the food up as I could, the did a 50% water change and the water is still murky. Do you guys have any suggestions?
__________________
RugbyBunny is offline   Reply With Quote
Old 04-23-2011, 02:45 AM   #19
Aquarium Advice Addict
 
Mr. Limpet's Avatar
 
Join Date: Mar 2011
Location: Northern California (Marin)
Posts: 4,505
Quote:
Originally Posted by RugbyBunny
I syphoned as much of the food up as I could, the did a 50% water change and the water is still murky. Do you guys have any suggestions?
Keep doing big PWC everyday till it's gone and 2x a day is ok too. I use poly-fil in my AC50 to polish my water and while I'm dealing with tannins from new DW, I change it out once a week or so filled with junk from the DW so maybe try that.
__________________
Mr. Limpet is offline   Reply With Quote
Old 04-23-2011, 10:09 AM   #20
Aquarium Advice Addict
 
BigJim's Avatar
 
Join Date: Jul 2009
Location: Oak Forest, IL
Posts: 4,388
I don't really care for any ammonia reducing chemical filter media. My biofilter takes care of the ammonia. I run sponges and the ceramic biomedia, using carbon only when I want to remove medication or tannins from the water.

Try adding a second sponge to the filter. It's possible the original sponge may have broken down a bit and is allowing some stuff to slip through.
__________________

__________________
A man's errors are his portals of discovery.
Guide to The Fishless Cycle Cycling With Fish
My DIY LED Light Fixture
Feel free to PM me directly with questions.
BigJim is offline   Reply With Quote
Reply

Tags
aquaclear, clear, filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
new aquaclear filter aquabeast Freshwater & Brackish - General Discussion 14 04-06-2011 08:47 PM
Aquaclear filter question kilfrg7864 General Hardware/Equipment Discussion 17 08-02-2009 03:14 PM
AquaClear filter the_elvish_misfit Freshwater & Brackish - General Discussion 10 04-08-2009 09:23 AM
Aquaclear Filter leaking telesto General Hardware/Equipment Discussion 13 03-25-2005 01:54 PM
Aquaclear Filter? eykis9 General Hardware/Equipment Discussion 11 09-10-2003 07:57 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 03:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.