Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 10-29-2011, 02:33 PM   #1
Aquarium Advice Freak
 
Koikid88's Avatar
 
Join Date: Oct 2011
Location: Toronto
Posts: 409
AquaClear Heater

So I purchased a 150w Aquaclear heater.

First thing I noticed, it's very difficult to keep the heater in place. The suction cups slide when doing anything in the tank. The clips seem 'too loose' around the glass cylinder.

I know they aren't full time heaters, and shut off when the temp is reached, but why does it always let the water drop well below the temp before turning on?

Sometimes the water is room temperature, (and it's fall here).


Sometimes it's because the heater randomly slips out of the inconvenient range of minimum/maximum water height, but other times it's still in the right position, but doesn't turn on until I fiddle with it or change temperature.

Does anyone else have problems with these?
__________________

__________________
Koikid88 is offline   Reply With Quote
Old 10-30-2011, 02:43 AM   #2
Aquarium Advice Regular
 
HB87's Avatar
 
Join Date: Aug 2011
Location: Missouri
Posts: 96
Im having the same problem. I thought maybe i just got a defective heater... Guess not. :-/
__________________

__________________
HB87 is offline   Reply With Quote
Old 10-30-2011, 11:05 PM   #3
Aquarium Advice Freak
 
Koikid88's Avatar
 
Join Date: Oct 2011
Location: Toronto
Posts: 409
**** ok, now I know I'm not alone, probably going to return for a more reliable brand.
I'm just glad it's in my shrimp/snail tank and not in with the fish
__________________
Koikid88 is offline   Reply With Quote
Old 11-02-2011, 12:08 AM   #4
Aquarium Advice Regular
 
Rachel0001's Avatar
 
Join Date: Aug 2011
Location: Gig Harbor, WA
Posts: 93
I've had the same issues recently. I've replaced all my heaters but one with the aqueon pro (black, non glass) heaters. One of the glass ones cracked and started turning white inside last week - thank god I was standing by the tank and heard it! It was only 6-8 weeks old.
__________________
Rachel0001 is offline   Reply With Quote
Reply

Tags
aquaclear, clear, eat, eater, heater

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
45-50 Gallon Aquarium Heater and Watts modestvolta Freshwater & Brackish - General Discussion 3 09-23-2011 05:05 PM
need heater recommendations -=Jeff=- General Hardware/Equipment Discussion 7 09-11-2011 10:26 PM
Aqueon Pro 50 Watt heater problem! Help please! Stef Freshwater & Brackish - Getting Started 5 09-11-2011 01:24 AM
Fluval e50 Heater Brian_Nano12g General Hardware/Equipment Discussion 3 08-31-2011 03:40 PM
Hydor Theo heater malfunctioning? Aqua315 Freshwater & Brackish - General Discussion 0 07-04-2011 08:01 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 04:12 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.