Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-07-2013, 02:08 AM   #1
Aquarium Advice Apprentice
 
Join Date: Nov 2013
Location: The wild, wild West
Posts: 11
Question Broken Aquaclear 110 Filter?

My boyfriend and I ony recently purchased a 36 gallon tank, which included the Aquaclear 110. Today at some point, the filter ran itself dry and when we returned home at the end of the day will not run at all. I'm hoping there might be an easy solution, as purchasing a new filter would not be ideal. Thank you so much for any help you can offer!
__________________

__________________
8taktaktak8 is offline   Reply With Quote
Old 11-07-2013, 02:54 AM   #2
Aquarium Advice Addict
 
bshenanagins's Avatar
 
Join Date: Feb 2013
Posts: 1,583
Will the filter impeller spin? Because if that actual motor is toast then you just need to get a new motor which you could prob get for a decent deal online. Take it off the filter and plug it in, if it spins your fine. Just fill the filter and then plug it in. Make sure your water level isn't too low also because that will affect its ability to siphon. It may take a few minutes for the siphon to reach the bend so give it time
__________________

__________________
bshenanagins is offline   Reply With Quote
Old 11-07-2013, 03:26 AM   #3
Aquarium Advice Freak
 
lbirath001's Avatar
 
Join Date: Jun 2013
Posts: 299
Where did you buy it? Petsmart will take back the filter if you just got it. Just tell them it stopped working
__________________
lbirath001 is offline   Reply With Quote
Old 11-07-2013, 06:19 AM   #4
Aquarium Advice Apprentice
 
Join Date: Nov 2013
Posts: 24
Fill up the filter with water (while it's on the tank) and plug it in.

Take out the filter tube and use the pointed end to apply a little pressure to the top of the impeller "fan".

I have to do this with all of my Aquaclears after the housing empties itself of water during normal water changes.

I hope this works for you....
__________________
Tracy Bird is offline   Reply With Quote
Old 11-08-2013, 02:39 AM   #5
Aquarium Advice Regular
 
ole scratch's Avatar
 
Join Date: Aug 2013
Posts: 61
Take the motor off. Pull impeller and shift out. If there is any crud in the motor housing, or on the impeller or shaft, that can stop it dead. If messed up, look into an aqueous quite flow 55/75. I have had both the 110 and 55/75. The 55/75 is much more efficient and a lot more dependable than the 110, in my experience. Just be careful with fine substrate or sand. And that goes with both filters. The 110 has way to much water bypass anyways. Yes, I am against any hagen products. But that is due to experience and lack of customer service and product support. Fluval and aquaclear both will not honor product warranty. And that is from personal experience. The 55/75 is half the cost, and, if u can think outside the box, just as customizable as the 110.
__________________
ole scratch is offline   Reply With Quote
Old 11-08-2013, 11:13 AM   #6
Aquarium Advice Apprentice
 
Join Date: Nov 2013
Location: The wild, wild West
Posts: 11
I spent yesterday evening cleaning the impeller and inside the impeller well with q-tips and it works!!! The filter came with the fully established tank, so I got it secondhand. The woman I purchased it from had bought it from Amazon last spring, and it was supposed to have a lifetime warranty, but talking with her we weren't even sure how to go about getting that warranty honored. Hopefully, we will get that figured out in the near future, in case something goes wrong.

Thanks for all the help and advice!
__________________

__________________
8taktaktak8 is offline   Reply With Quote
Reply

Tags
aquac, aquaclear, clear, filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.