Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 05-16-2006, 04:03 AM   #1
Aquarium Advice Freak
 
Viperboy's Avatar
 
Join Date: Mar 2006
Location: Lawrence, KS
Posts: 383
Send a message via AIM to Viperboy
Cleaning a Emperor 280

Just like it says ... i think my emperor is getting dirty kind of in the section where water is pumped so i think i need to clean it i guess. Water seems to be flowing into the filter good but just a little bit is flowing back out over the intake .... is this bad? .... also my main question is are there any like sites that show how to clean this filter or does anyone know how to take it apart or whatever and clean it.
Also will it be ok for my tank to be without a filter while i clean it ... say like 10 to 15 mins or however long it takes to clean it ... TIA

Ray
__________________

__________________
Viperboy is offline   Reply With Quote
Old 05-16-2006, 09:02 AM   #2
Aquarium Advice Addict
 
severum mama's Avatar


 
Join Date: Dec 2004
Location: GA
Posts: 10,297
The same way you put it together is the same way you take it apart. Use the included brush to clean the intake tube and the plastic cap on the bottom of the tube. Take the spray bar out and use the brush on the inside of it, although I can't imagine your filter is old enough to need the spray bar cleaned. Pull the impeller housing out and brush it off. Check the impeller to make sure there's no gunk built up on it, or eventually the filter will start to run really loud. Float the Biowheel in the tank while you're cleaning the filter. If your cartridge is dirty, rinse it in a bucket of tankwater. That's how I clean mine anyway. Your tank will be fine without a filter running on it in the time it takes you to clean it.
__________________

severum mama is offline   Reply With Quote
Old 05-16-2006, 12:13 PM   #3
Aquarium Advice Addict
 
Lonewolfblue's Avatar
 
Join Date: Jul 2005
Location: Wenatchee, WA
Posts: 8,435
Send a message via ICQ to Lonewolfblue Send a message via Yahoo to Lonewolfblue
Just keep your media wet and the biowheel wet. Put them in a bucket of tank water. Then take the filter apart and clean it out. Is the water flowing over the top of the filter pad? If it is, then just change the filter pad or rinse it out well. It does go over the intake if the pad is getting clogged. Do you see water in the window to the right of the biowheel? If so, the pad is just getting clogged. You may not even need to clean out the filter itself.
__________________
55G Filstar XP3 - 16" Fire Eel
75G Medium Planted - Filstar XP3 Low Light - Established Feb 2006
Lonewolfblue is offline   Reply With Quote
Old 05-16-2006, 02:49 PM   #4
Aquarium Advice Freak
 
Viperboy's Avatar
 
Join Date: Mar 2006
Location: Lawrence, KS
Posts: 383
Send a message via AIM to Viperboy
Its not flowing over the filter pad but yes there is water in the window to the right of the biowheel thats where it is flowing back out sort of next to the intake tube ..... glad to hear it is just my pad being clogged and not something like the impeller .... i have not cleaned anything on the filter since i set up my tank about 2 months ago so i hope that is just it and ill clean the filter pad out in some tank water and see what happens.

When i clean the filter pad out in some tank water i dont really need to turn my filter off to do that do I?

Thanks guys

Ray
__________________
Viperboy is offline   Reply With Quote
Reply

Tags
clean, cleaning

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Emperor 280 Viperboy General Hardware/Equipment Discussion 6 04-22-2008 08:08 PM
Opinion on a Emperor BIO-Wheel Powerfilters Emperor 280 filter Rtrecost General Hardware/Equipment Discussion 5 01-19-2008 05:02 PM
emperor 280 noise glooey General Hardware/Equipment Discussion 9 05-03-2005 06:27 AM
Emperor 280 Fish_fanatic Saltwater Reef Aquaria 3 01-25-2005 11:05 PM
Emperor 400 or 280 mayreee General Hardware/Equipment Discussion 2 10-28-2004 03:22 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.