Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 07-06-2009, 12:38 PM   #1
Aquarium Advice Freak
 
Join Date: Jul 2009
Posts: 226
Eclipse 2 pump issue HELP

I recently picked up a 25 gallon with eclipse 2 hood. The pump is a little loud.

This was a used saltwater tank.... how do you know when to change the impeller?

Any suggestions, I will be using this as a Chichlid tank.

PS: I'm new to the tank world be easy haha
__________________

__________________
jason1985 is offline   Reply With Quote
Old 07-06-2009, 12:53 PM   #2
Aquarium Advice Activist
 
darkmule27's Avatar
 
Join Date: Jan 2009
Location: Virginia
Posts: 133
http://www.aquatichouse.com/tanks_fi...pse_manual.pdf

page 8 is probably the most helpful about the impeller

clean the impeller with hot water and vinegar and run hot water through it to clean out salt gunk. No soap! The manual also talks about cleaning.

Hopefully this helps!
__________________

__________________
Q: Why do chemists like nitrates so much?
A: They're cheaper than day rates.
darkmule27 is offline   Reply With Quote
Old 07-06-2009, 03:41 PM   #3
Aquarium Advice Addict
 
severum mama's Avatar


 
Join Date: Dec 2004
Location: GA
Posts: 10,297
What kind of cichlids? A 25 gallon isn't really suitable for any cichlids other than SA dwarfs, kribs, or Tanganyikan shell dwellers IMO.
severum mama is offline   Reply With Quote
Old 07-07-2009, 01:05 AM   #4
Aquarium Advice Freak
 
Join Date: Jul 2009
Posts: 226
I have a few young Labidochromis caeruleus in a 10 gallon that will be transfered over to this 25 gallon tank. The 10 gallon will be turned into a planted.

I want to get into Salt water but i have some learning to do first so i am starting small
__________________
jason1985 is offline   Reply With Quote
Reply

Tags
eclipse, pump

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
37 gal Eclipse Filter pump is dead, is it revivable petstuffresale General Hardware/Equipment Discussion 0 04-01-2009 05:13 PM
eclipse-2 pump not pumping makiny awful noise RedRain5 Freshwater & Brackish - Getting Started 4 01-15-2007 08:50 PM
Return Pump - Hard Plumbing issue fishman General Hardware/Equipment Discussion 4 02-24-2006 06:00 PM
Skimmer's pump and return pump together? Is it ok? xxnonamexx General Hardware/Equipment Discussion 9 02-11-2006 01:30 AM
Eclipse 3 Lighting issue? rcjubei General Hardware/Equipment Discussion 2 02-08-2005 07:57 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 03:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.