Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-19-2013, 05:23 AM   #1
Aquarium Advice Addict
 
_skyla_'s Avatar
 
Join Date: Aug 2012
Location: western australia
Posts: 1,028
Eheim classic canister filter ?

Does anyone have experience with one of these and might be able to help me out?
Mine eheim classic 350 canister was working great when I first got it which wasn't that long ago.
The intake doesn't seem to be sucking as hard as it was before and the out flow was a lot stronger.
I cleaned it out checked the impeller and the tubing I managed to get it flowing a bit better but it's just not working as we'll anymore. It doesn't seem to be picking up the free floating partials and junk in the water either.
The metal clips that hold the motor head on top also seem to not be fitting as tightly maybe they have stretched? Any way if anyone has any ideas of what could be going on I'd appreciate it.
__________________

__________________
_skyla_ is offline   Reply With Quote
Old 03-19-2013, 08:07 AM   #2
Aquarium Advice Addict
 
Cynic's Avatar
 
Join Date: Dec 2011
Posts: 1,272
How long have you let it run for? In my experience it can take a little while for the water flow to return to full pressure.

Other things to consider, are the valves fully open? Obvious I know but thought I'd check.

If it's still not working trying draining it of water and re-priming it...as gross as that is.
__________________

__________________
Cynic is offline   Reply With Quote
Old 03-19-2013, 09:38 AM   #3
Aquarium Advice Addict
 
_skyla_'s Avatar
 
Join Date: Aug 2012
Location: western australia
Posts: 1,028
Quote:
Originally Posted by Cynic View Post
How long have you let it run for? In my experience it can take a little while for the water flow to return to full pressure.

Other things to consider, are the valves fully open? Obvious I know but thought I'd check.

If it's still not working trying draining it of water and re-priming it...as gross as that is.
It was playing up before I even cleaned it out its a bit better after I got some gunk out but not as good as it was when I first set it up and got it going which was only about a month ago. I have drained it twice but I'll try once more tomorrow I only primed it the first time the other times I just filled it up with tank water before I turned it on so ill try and prime it by sucking on the intake tube again. Oh and yes the valves are fully open
__________________
_skyla_ is offline   Reply With Quote
Old 03-19-2013, 01:53 PM   #4
Aquarium Advice Addict
 
Cactuspixie's Avatar
 
Join Date: Jan 2013
Location: Queensland Australia
Posts: 1,830
I have the same filter on one of my tanks- I prime it using the water jet from a power head.
__________________
Cactuspixie is offline   Reply With Quote
Old 03-19-2013, 04:45 PM   #5
Aquarium Advice Addict
 
Cynic's Avatar
 
Join Date: Dec 2011
Posts: 1,272
Quote:
Originally Posted by _skyla_ View Post

It was playing up before I even cleaned it out its a bit better after I got some gunk out but not as good as it was when I first set it up and got it going which was only about a month ago. I have drained it twice but I'll try once more tomorrow I only primed it the first time the other times I just filled it up with tank water before I turned it on so ill try and prime it by sucking on the intake tube again. Oh and yes the valves are fully open
Repriming once drained is the best I can offer. I have two 2217s and they both have had the issue with low flow re-priming fixed mine. Just wish the process involved less choking on tank water -.-
__________________
Cynic is offline   Reply With Quote
Old 03-19-2013, 07:13 PM   #6
Aquarium Advice Addict
 
_skyla_'s Avatar
 
Join Date: Aug 2012
Location: western australia
Posts: 1,028
Quote:
Originally Posted by Cynic View Post

Repriming once drained is the best I can offer. I have two 2217s and they both have had the issue with low flow re-priming fixed mine. Just wish the process involved less choking on tank water -.-
Ok thank you I will try that then, yes it's not the nicest thing but oh well gotta do it!
__________________

__________________
_skyla_ is offline   Reply With Quote
Reply

Tags
canister, canister filter, eheim, filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 04:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.