Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 03-08-2009, 04:53 PM   #1
Aquarium Advice Apprentice
Join Date: Nov 2008
Posts: 28
eheim filter noise question

I have been running my Eheim 2213 filter for about 2 months now and it just started making nose. Before it used to be almost silent but now its making a sort of crackling or grinding noise.

Anyone have the same problem with their filter? Do you know how to fix it?

Naws is offline   Reply With Quote
Old 03-09-2009, 01:51 AM   #2
Aquarium Advice Apprentice
Egress's Avatar
Join Date: Jan 2006
Location: California, USA
Posts: 36
Send a message via ICQ to Egress Send a message via AIM to Egress
I've never owned an Eheim canister, but the first thing I would try is to clean the impeller and the impeller well (the area the impeller sits in). I would also make sure the impeller was securely seated when putting it back in, some motor assemblies allow for the impeller to piston in the well. In my experience that covers most abnormal noises in filter motors.

Egress is offline   Reply With Quote
Old 03-09-2009, 06:38 AM   #3
Thanx but no.....

Join Date: Jun 2008
Posts: 2,333
CaptainAhab is offline   Reply With Quote
Old 03-10-2009, 07:00 AM   #4
Aquarium Advice Freak
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
I have a Rena XP 2 that was spitting air. It was driving us nuts.
I checked everything and couldn't find a leak. Put new vinyl hoses on it,
cleaned the impeller assy, re lubed the o-rings & seals.
The original hoses wee opaque. The vinyl ones are clear, when I lookied
at the intake hase while it was pumping, I could see air bubbles. So I taped it up.

Here is my first thread:
Rena SP2 pumping bubbles

Then I found ABOUT where the leak was:


It was a primitive fix but till I can order a new intake neck it'll do.

Good luck
cbwmn is offline   Reply With Quote
Old 03-16-2009, 06:29 PM   #5
Aquarium Advice Apprentice
Join Date: Nov 2008
Posts: 28
I replaced the impeller shaft and it fixed the problem
Naws is offline   Reply With Quote

eheim, filter, noise

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Eheim Classic Question - Is the Carbon Filter Beneficial? PrettyFishies Freshwater & Brackish - Planted Tanks 8 04-25-2007 08:14 PM
EHEIM CANSITER FILTER QUESTION kaz General Hardware/Equipment Discussion 6 03-14-2006 11:14 PM
eheim filter question woo Freshwater & Brackish - General Discussion 2 07-17-2005 06:54 AM
Eheim ECCO Filter question? jasno999 General Hardware/Equipment Discussion 3 10-20-2004 08:04 AM
Quick question on Eheim filter balls... MarkW19 Saltwater & Reef - Getting Started 11 05-16-2004 02:33 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:57 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.