Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-08-2009, 05:53 PM   #1
Aquarium Advice Apprentice
 
Join Date: Nov 2008
Posts: 28
eheim filter noise question

I have been running my Eheim 2213 filter for about 2 months now and it just started making nose. Before it used to be almost silent but now its making a sort of crackling or grinding noise.

Anyone have the same problem with their filter? Do you know how to fix it?
__________________

__________________
Naws is offline   Reply With Quote
Old 03-09-2009, 02:51 AM   #2
Aquarium Advice Apprentice
 
Egress's Avatar
 
Join Date: Jan 2006
Location: California, USA
Posts: 36
Send a message via ICQ to Egress Send a message via AIM to Egress
I've never owned an Eheim canister, but the first thing I would try is to clean the impeller and the impeller well (the area the impeller sits in). I would also make sure the impeller was securely seated when putting it back in, some motor assemblies allow for the impeller to piston in the well. In my experience that covers most abnormal noises in filter motors.
__________________

__________________
Egress is offline   Reply With Quote
Old 03-09-2009, 07:38 AM   #3
Thanx but no.....


 
Join Date: Jun 2008
Posts: 2,333
__________________
CaptainAhab is offline   Reply With Quote
Old 03-10-2009, 08:00 AM   #4
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Naws
I have a Rena XP 2 that was spitting air. It was driving us nuts.
I checked everything and couldn't find a leak. Put new vinyl hoses on it,
cleaned the impeller assy, re lubed the o-rings & seals.
The original hoses wee opaque. The vinyl ones are clear, when I lookied
at the intake hase while it was pumping, I could see air bubbles. So I taped it up.

Here is my first thread:
Rena SP2 pumping bubbles

Then I found ABOUT where the leak was:

http://www.aquariumadvice.com/forums/f60/to-all-rena-xp-owners-113479.html

It was a primitive fix but till I can order a new intake neck it'll do.

Good luck
Charles
__________________
cbwmn is offline   Reply With Quote
Old 03-16-2009, 07:29 PM   #5
Aquarium Advice Apprentice
 
Join Date: Nov 2008
Posts: 28
I replaced the impeller shaft and it fixed the problem
__________________
Naws is offline   Reply With Quote
Reply

Tags
eheim, filter, noise

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eheim Classic Question - Is the Carbon Filter Beneficial? PrettyFishies Freshwater & Brackish - Planted Tanks 8 04-25-2007 09:14 PM
EHEIM CANSITER FILTER QUESTION kaz General Hardware/Equipment Discussion 6 03-15-2006 12:14 AM
eheim filter question woo Freshwater & Brackish - General Discussion 2 07-17-2005 07:54 AM
Eheim ECCO Filter question? jasno999 General Hardware/Equipment Discussion 3 10-20-2004 09:04 AM
Quick question on Eheim filter balls... MarkW19 Saltwater & Reef - Getting Started 11 05-16-2004 03:33 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.