Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 04-21-2008, 02:44 AM   #1
Aquarium Advice Freak
 
Viperboy's Avatar
 
Join Date: Mar 2006
Location: Lawrence, KS
Posts: 383
Send a message via AIM to Viperboy
Emperor 280

Got a Emperor 280 off of a deal through craigslist with my new tank and when i plug it in nothing happens ... doesnt even make a noise. Anyone have a clue what could be wrong with it? .... outlet i used it on does work.
__________________

__________________
Viperboy is offline   Reply With Quote
Old 04-21-2008, 11:37 AM   #2
Aquarium Advice Freak
 
warped1's Avatar
 
Join Date: Mar 2008
Location: South Philly, Pa.
Posts: 364
Does it have the impeller assembly? It is a tubular magnet with what looks like a propeller on top that fits inside the motor - Also does the motor feel like it is slightly vibrating when you plug it in and do you feel any warmth on the motor?
__________________

__________________
warped1 is offline   Reply With Quote
Old 04-21-2008, 12:40 PM   #3
AA Team Emeritus
 
roka64's Avatar
 
Join Date: Mar 2006
Posts: 13,860
Send a message via AIM to roka64 Send a message via Yahoo to roka64
It sounds like you have a bad motor or the impeller is stuck. Can you take it apart and soak the parts in vinegar, to clean them?
__________________
Age is relative, you are only as old as you act....of course, this works in reverse....

Questions loved, heeded advice greatly appreciated!

Vote for AA
Good reading about:
Nitrogen Cycle
Fishless Cycling
Need more help?
Articles
Acronym List

--Scott
roka64 is offline   Reply With Quote
Old 04-21-2008, 07:17 PM   #4
Aquarium Advice Freak
 
Viperboy's Avatar
 
Join Date: Mar 2006
Location: Lawrence, KS
Posts: 383
Send a message via AIM to Viperboy
it is setup at my girlfriends so when i go back over there tonight for dinner i am gonna do some tests with the motor and impeller and see whats up but i did try to feel the motor housing when i had it pluged in and didnt feel anything
__________________
Viperboy is offline   Reply With Quote
Old 04-22-2008, 03:13 PM   #5
Aquarium Advice Freak
 
Viperboy's Avatar
 
Join Date: Mar 2006
Location: Lawrence, KS
Posts: 383
Send a message via AIM to Viperboy
messed around with it a little and got it working
__________________
Viperboy is offline   Reply With Quote
Old 04-22-2008, 04:24 PM   #6
Aquarium Advice Addict
 
pitt420dude's Avatar
 
Join Date: Mar 2005
Location: Pittsburgh! Home of the 6 Time Superbowl Champs!
Posts: 1,050
Send a message via AIM to pitt420dude
Yay! I dunno why some powerheads are like that, they just need a tinkering and they're A-ok.
__________________
Thank you so much for all your help. I'm back into the hobby with a new vigor!

LOOK! A NEW LEAF!!!!!
pitt420dude is offline   Reply With Quote
Old 04-22-2008, 08:08 PM   #7
Aquarium Advice Freak
 
warped1's Avatar
 
Join Date: Mar 2008
Location: South Philly, Pa.
Posts: 364
Very glad to hear that - Happy fish keeping :p
__________________

__________________
warped1 is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Emperor 280 humming? krap101 General Hardware/Equipment Discussion 8 03-09-2009 11:25 PM
Opinion on a Emperor BIO-Wheel Powerfilters Emperor 280 filter Rtrecost General Hardware/Equipment Discussion 5 01-19-2008 05:02 PM
Cleaning a Emperor 280 Viperboy General Hardware/Equipment Discussion 3 05-16-2006 02:49 PM
Emperor 280 Fish_fanatic Saltwater Reef Aquaria 3 01-25-2005 11:05 PM
Emperor 280 Filter bobtrop General Hardware/Equipment Discussion 12 11-15-2004 10:56 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 09:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.