Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 07-17-2012, 08:57 PM   #1
Aquarium Advice Apprentice
 
kbiedak's Avatar
 
Join Date: Apr 2012
Posts: 15
eshopps psk75H protein skimmer

I just bought this skimmer and it is not working, help!! It's all set up right and we followed the directions but nothin is happening.
__________________

__________________
kbiedak is offline   Reply With Quote
Old 07-17-2012, 09:49 PM   #2
Aquarium Advice Addict
 
Daniel Fishy's Avatar
 
Join Date: Jun 2012
Location: Jupiter Fla
Posts: 1,178
Do you have the water level at the neck under the collection cup? Not the bubbles but the water.There is a break in period. I have the 100 it took a few weeks for mine. How old is your tank and how clean it is weighs in also.
__________________

__________________
Daniel Fishy is offline   Reply With Quote
Old 07-17-2012, 10:26 PM   #3
Aquarium Advice Apprentice
 
kbiedak's Avatar
 
Join Date: Apr 2012
Posts: 15
Quote:
Originally Posted by Daniel Fishy
Do you have the water level at the neck under the collection cup? Not the bubbles but the water.There is a break in period. I have the 100 it took a few weeks for mine. How old is your tank and how clean it is weighs in also.
Uh the tank is a few months old and there are five fish in it but relatively clean. I only filled it with water more than halfway because thats what the directions said. It sounds like there is air in the pump or something
__________________
kbiedak is offline   Reply With Quote
Old 07-17-2012, 11:21 PM   #4
Aquarium Advice Addict
 
Daniel Fishy's Avatar
 
Join Date: Jun 2012
Location: Jupiter Fla
Posts: 1,178
Did you pinch the air line till it reach the top of the main cylinder the blue rim?
__________________
Daniel Fishy is offline   Reply With Quote
Old 07-17-2012, 11:40 PM   #5
Aquarium Advice Apprentice
 
kbiedak's Avatar
 
Join Date: Apr 2012
Posts: 15
Quote:
Originally Posted by Daniel Fishy
Did you pinch the air line till it reach the top of the main cylinder the blue rim?
That's the thing the water didn't rise when I did that
__________________
kbiedak is offline   Reply With Quote
Old 07-17-2012, 11:48 PM   #6
Aquarium Advice Addict
 
Daniel Fishy's Avatar
 
Join Date: Jun 2012
Location: Jupiter Fla
Posts: 1,178
Mine did that once when I turned it off try unplugging it add some more water pinch the hose an have someone plug it in for you
__________________
Daniel Fishy is offline   Reply With Quote
Old 07-18-2012, 12:58 AM   #7
Aquarium Advice Apprentice
 
kbiedak's Avatar
 
Join Date: Apr 2012
Posts: 15
Quote:
Originally Posted by Daniel Fishy
Mine did that once when I turned it off try unplugging it add some more water pinch the hose an have someone plug it in for you
Ok thank you so much!
__________________
kbiedak is offline   Reply With Quote
Old 07-18-2012, 12:17 PM   #8
Aquarium Advice Addict
 
Daniel Fishy's Avatar
 
Join Date: Jun 2012
Location: Jupiter Fla
Posts: 1,178
You get it going?
__________________
Daniel Fishy is offline   Reply With Quote
Old 07-18-2012, 12:35 PM   #9
Aquarium Advice Apprentice
 
kbiedak's Avatar
 
Join Date: Apr 2012
Posts: 15
Quote:
Originally Posted by Daniel Fishy
You get it going?
Nope not yet
__________________
kbiedak is offline   Reply With Quote
Old 07-18-2012, 12:38 PM   #10
Aquarium Advice Apprentice
 
kbiedak's Avatar
 
Join Date: Apr 2012
Posts: 15
Quote:
Originally Posted by Daniel Fishy
You get it going?
The airtube keeps getting filled with water and the water level in the main chamber won't stay up, it keeps dropping
__________________

__________________
kbiedak is offline   Reply With Quote
Reply

Tags
eshopps, protein, protein skimmer, skimmer

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 01:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.