Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 08-14-2005, 09:43 PM   #1
Aquarium Advice Activist
 
Join Date: Jun 2005
Location: Flagstaff, AZ
Posts: 148
Filter question?

I have a Whisper Power filter 20 for my 20 gallon tank. While doing some maintenace, I notice the water has starting to flow back out from the chamber where the main tube comes up from the tank. Any ideas on why and how to correct this problem?
__________________

__________________
hb3133 is offline   Reply With Quote
Old 08-14-2005, 10:47 PM   #2
Aquarium Advice Freak
 
Join Date: May 2004
Location: Peoria,IL
Posts: 348
It's time to replace the filter cartridge.


Kim
__________________

__________________
LittlePuff is offline   Reply With Quote
Old 08-14-2005, 10:51 PM   #3
Aquarium Advice Addict
 
krap101's Avatar
 
Join Date: Feb 2004
Location: Roscoe, IL
Posts: 6,084
Send a message via AIM to krap101
not exactly replace it. most people say swish it around in used tankwater, but i find washing it with a hose works better. but if you live in a city you'll probally have chlorine in your water.
__________________
~ Danny
krap101 is offline   Reply With Quote
Old 08-14-2005, 11:26 PM   #4
AA Team Emeritus
 
TankGirl's Avatar
 
Join Date: May 2003
Location: Richmond VA
Posts: 8,974
Also clean out the intake tube as these get coated and slow down the flow - but the main problem definitely sounds lke a clogged cartridge. I rinse them out under strong tap water, but only if the tank is mature and not recently cycled.
TankGirl is offline   Reply With Quote
Old 08-20-2005, 07:10 PM   #5
Aquarium Advice Activist
 
Join Date: Jun 2005
Location: Flagstaff, AZ
Posts: 148
After swishing around the Whisper Bio-bag filter cartridge in the tank water I had just emptied, the filter worked fine. But now the same problem is occuring after only a few days. Should I just buy a new filter cartridge?
__________________
hb3133 is offline   Reply With Quote
Old 08-20-2005, 07:42 PM   #6
Aquarium Advice Addict
 
Join Date: May 2005
Location: Central Kentucky
Posts: 6,015
Send a message via AIM to greenmaji
did you swish it in the tank or the tank water in a bag or bucket then dispose of the dirty water?
it takes pretty vigorus cleaning to get it up to par IME..
__________________
greenmaji is offline   Reply With Quote
Old 08-20-2005, 09:07 PM   #7
Aquarium Advice Activist
 
Join Date: Jun 2005
Location: Flagstaff, AZ
Posts: 148
I cleaned it in the water changing bucket, after doing a 20% water change. It seems to be working fine now. I think I now know what I did differently the first time. During the first filter cleaning, I just swished the filter bag in the water. This time I swished and also squeezed the bag numerous times. I hope this does the job.
__________________
hb3133 is offline   Reply With Quote
Old 08-21-2005, 02:47 AM   #8
Aquarium Advice Addict
 
Join Date: May 2005
Location: Central Kentucky
Posts: 6,015
Send a message via AIM to greenmaji
The filter floss bag needed weekly cleaning on all of my Whisper filters.. It traps gunk well but having to clean it is the price I had to pay. :P
__________________

__________________
greenmaji is offline   Reply With Quote
Reply

Tags
filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Filter Question CluelessInNY Saltwater & Reef - Getting Started 10 07-12-2008 03:18 PM
Filter Question KiGrind General Hardware/Equipment Discussion 5 11-01-2006 12:41 AM
I have a filter question please Bosk General Hardware/Equipment Discussion 13 04-28-2005 08:09 AM
New QT filter question tmcpeek Saltwater Fish Only & FOWLR 9 10-12-2004 07:35 PM
Filter Question Kwenbee General Hardware/Equipment Discussion 11 03-12-2004 12:11 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.