Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-30-2005, 01:36 PM   #1
Aquarium Advice Freak
 
Join Date: Nov 2005
Location: Canada
Posts: 210
Filtration issues

I've been reading that using AC in a planted tank is bad because it takes nutrients out of the water. I have taken out the AC from my emperor 400 HOB filter and I was wondering what else I could use instead. Is filter floss a good option?

I've also noticed that there is a whitish fog in my tank. What could be causing this? I did a 20% water change, which cleared it up a bit, but it returned the next day. Could it be that my tank is not being filtered right? All my water params are ok as well.
__________________

__________________
Friendly is offline   Reply With Quote
Old 11-30-2005, 03:21 PM   #2
Aquarium Advice Freak
 
Join Date: Nov 2005
Location: Canada
Posts: 210
I just re-read the "Filtration guide for the planted aquarium" again and filter floss is a good alternative to AC, so nm about that
__________________

__________________
Friendly is offline   Reply With Quote
Old 11-30-2005, 03:28 PM   #3
Aquarium Advice Addict
 
Join Date: Dec 2003
Location: Nebraska, USA
Posts: 6,703
and to clear up the myth, AC isn't gonna remove that much trace nutrient to have a huge effect on levels.
The bigger issue is: in a healthy planted tank, constant use of AC shouldn't be necessary, so why take the time and $$ to do it?
__________________
Former advisor and planted tank geek...life's moved on though.
malkore is offline   Reply With Quote
Reply

Tags
filtration

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RO/DI issues boxxmann General Hardware/Equipment Discussion 6 01-11-2009 11:02 PM
Filtration issues Latitude_change General Hardware/Equipment Discussion 3 08-27-2008 10:26 AM
Filtration issues, or lack-there-of filtration... penelope Freshwater & Brackish - Getting Started 9 03-02-2008 08:22 PM
Still having some issues Talon242 Freshwater & Brackish - Planted Tanks 10 12-02-2004 03:42 AM
Filtration/Water Quality Issues with Fry Brandon General Hardware/Equipment Discussion 1 05-26-2003 09:12 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.