Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 04-13-2016, 11:25 PM   #1
Aquarium Advice Apprentice
 
sc166's Avatar
 
Join Date: Jun 2015
Posts: 36
Fluval C3 Filter humming but not filtering water

I just turned off all my equipment (including the filter) for my routine cleaning. When I turned it back on and my filter wouldn't run water. It's humming so I know it's getting power. I plugged it into different outlets but no luck. Any help?


Sent from my iPhone using Aquarium Advice
__________________

__________________
sc166 is offline   Reply With Quote
Old 04-13-2016, 11:30 PM   #2
Aquarium Advice Activist
 
Join Date: Nov 2015
Location: Midwest U.S.
Posts: 186
Sometimes when they're off long enough, filters need to be primed. Just fill the filter compartments with water using a cup, etc. If that doesn't get it going, could be something else, like a large clog or it may just be time for a new filter. But the fact that it's humming makes me think it just needs primed.
__________________

__________________
3g betta, 29g molly, 90g Amer cichlid, 90g community, 137g African cichlid, 220g water garden, 6,500g koi pond
Cecibella123 is offline   Reply With Quote
Old 04-14-2016, 03:03 PM   #3
Aquarium Advice Freak
 
Join Date: May 2015
Location: Woodstock,Ga
Posts: 201
Mine do that at times . Just take out the up lift tube and use a wooden skewer , Q tip , or something like that and give the impeller a little push . Should take right off .
__________________
We are meant to be the stewards of the Earth and her creatures....not the masters.
Leeatl is offline   Reply With Quote
Reply

Tags
ate, filter, fluval, val, water

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fluval 4plus filter not filtering properly buddy General Hardware/Equipment Discussion 1 07-17-2010 04:16 PM
Emperor 280 humming? krap101 General Hardware/Equipment Discussion 8 03-09-2009 11:25 PM
55gal humming along - what fish next? laxpatrick Freshwater & Brackish - Getting Started 3 03-06-2009 08:03 AM
My filter is making humming/buzzing noises Pilot Freshwater & Brackish - General Discussion 2 06-20-2006 07:06 AM
maxi-jets humming? bschnuck Saltwater Reef Aquaria 6 07-09-2004 02:54 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.