Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 11-09-2014, 01:33 AM   #1
Aquarium Advice Addict
 
NigelK8485's Avatar
 
Join Date: Oct 2014
Location: Louisville, KY
Posts: 1,431
Heater help

So I just set up my 150 gallon. In it I put two Aqueon Pro 250's. Hearing horror stories about heaters malfunctioning I decided to go on and buy a heater controller, a Finnex digital heater controller. It was all working fine, the heaters are set at 84, the controller at 78 and the tank stayed a constant 77.8-78 degrees. However I just noticed that the LED lights on the heaters are kind of blinking, dimming as if power is being cut from them. They're both plugged into the Finnex using an extension cord that has multiple outlets, I checked and unplugged them and plugged them in individually to a regular outlet and they were fine. Is this anything to be concerned about?


Sent from my iPad using Aquarium Advice
__________________

__________________
NigelK8485 is offline   Reply With Quote
Old 11-09-2014, 11:48 AM   #2
Aquarium Advice Addict
 
mikem691's Avatar
 
Join Date: Jul 2012
Location: Chicago
Posts: 4,673
It may be the controller flickering as its coming on or turning off. I have a heater that does that as its coming on.
__________________

__________________
mikem691 is offline   Reply With Quote
Old 11-09-2014, 04:22 PM   #3
Aquarium Advice Addict
 
NigelK8485's Avatar
 
Join Date: Oct 2014
Location: Louisville, KY
Posts: 1,431
I'm such an idiot. I was just messing with it and noticed I didn't have the extension cord plugged into the heater controller all the way. Problem solved.


Sent from my iPad using Aquarium Advice
__________________
NigelK8485 is offline   Reply With Quote
Old 11-09-2014, 04:45 PM   #4
Aquarium Advice Addict
 
mikem691's Avatar
 
Join Date: Jul 2012
Location: Chicago
Posts: 4,673
Quote:
Originally Posted by NigelK8485 View Post
I'm such an idiot. I was just messing with it and noticed I didn't have the extension cord plugged into the heater controller all the way. Problem solved.


Sent from my iPad using Aquarium Advice
That too will do it
__________________
mikem691 is offline   Reply With Quote
Reply

Tags
ate, eat, eater, heat, heater

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater or no Heater HELP em1981ma Freshwater & Brackish - Coldwater, Native Fish & Ponds 9 08-28-2014 06:53 AM
Emergency: house heater broken and no tank heater pklong Freshwater & Brackish - General Discussion 8 01-08-2014 12:33 AM
Wanted: 20-30 gallon filter and 15 gallon heater AND 10 gallon heater. wryly23 Archive 2 07-06-2012 01:13 AM
hydro external heater, rena smart heater? keenfish General Hardware/Equipment Discussion 2 03-17-2012 08:26 AM
In-Sump Heater vs. In-Tank Heater Aquaman99 General Hardware/Equipment Discussion 2 05-13-2010 06:24 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 05:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.