Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-13-2014, 07:44 PM   #1
Aquarium Advice Apprentice
 
Join Date: Jun 2014
Location: I live in Olive Branch MS just 5 minutes south of Memphis
Posts: 18
Help!! I can't seem to get my Eshopps protein skimmer working correctly

I just Recently purchased an entire set up including a insump Eshopp sk200 cone protein skimmer. The problem i am having is that, when i turn it on it produces too much foam. i have tried adjusting the valve all the way open and it doesn't help. the water level is something that i play with but unless it is about two inches deep it doesn't help either and i dont believe that is right. A guy at my LFS said it has to "season" could someone help clear this up for me?
__________________
justingadd6420 is offline   Reply With Quote
Reply

Tags
eshopps, pps pro, protein, protein skimmer, rot, skimmer

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New thermometer working correctly? katiekelsey Freshwater & Brackish - General Discussion 3 02-21-2014 08:22 PM
Eshopps protein skimmer priblems Fallrivermikey79 General Hardware/Equipment Discussion 8 09-09-2013 05:04 AM
eshopps psk75H protein skimmer kbiedak General Hardware/Equipment Discussion 17 07-19-2012 03:19 PM
Working correctly? --- cycling with fish Chess46 Freshwater & Brackish - Getting Started 7 10-24-2011 09:46 PM
Forum not working correctly in IE7 RE1 DonnBallenger Forum Admin & Announcements 3 09-21-2006 05:19 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 09:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.