Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-27-2009, 02:37 PM   #1
Aquarium Advice Activist
 
Join Date: Jan 2009
Location: Maine
Posts: 137
Help!!! My filter is screaming!!!

after giving my tank some new water, my filter sounded as if the motor was seizing or sucking air... so i disassembled the filter thinking that there was something jammed inside. after cleaning the motor out and the prop, i placed my filter back onto the tank. (its a hang on) and the noise is still there. there are like little blips every 2 or 3 seconds. what should i do.
__________________

__________________
enadeau12 is offline   Reply With Quote
Old 03-27-2009, 03:16 PM   #2
Aquarium Advice FINatic
 
Join Date: Aug 2008
Location: Southern CA
Posts: 616
Did you prime it properly?
__________________

__________________
bluerose is offline   Reply With Quote
Old 03-27-2009, 03:28 PM   #3
Aquarium Advice Activist
 
Join Date: Jan 2009
Location: Maine
Posts: 137
what do you mean properly???
__________________
enadeau12 is offline   Reply With Quote
Old 03-27-2009, 03:37 PM   #4
Aquarium Advice FINatic
 
Join Date: Aug 2008
Location: Southern CA
Posts: 616
Completely is a better word. If there wasn't enough water for the pump to pull in when you started the filter again it may have caused your problem (sucking air).

If it pulled in air only for a short period of time then it probably didn't overheat. If it pulled air for a while, though, your 'screaming' noise now could be due to heat damage I would think.
__________________
bluerose is offline   Reply With Quote
Old 03-27-2009, 03:48 PM   #5
Aquarium Advice Activist
 
Join Date: Jan 2009
Location: Maine
Posts: 137
it didnt pull air for more than 4 or 5 seconds
__________________
enadeau12 is offline   Reply With Quote
Old 03-27-2009, 05:30 PM   #6
Aquarium Advice Freak
 
colematthewmalaka's Avatar
 
Join Date: Feb 2009
Location: Three Hills, AB the wheat capital of Alberta!!!
Posts: 290
I just cleaned my filter an hour ago and it did the same thing. Is yours an aquaclear? Mine is and my problem was a air bubble in the intake tube that went down into the impeller, it was right above the airstone though so i moved the airstone and now it sounds normal.
__________________
colematthewmalaka is offline   Reply With Quote
Old 03-27-2009, 07:50 PM   #7
Aquarium Advice Activist
 
Join Date: Jan 2009
Location: Maine
Posts: 137
mine is an aquaclear but i found out what the problem is. something got stuck inbetween my impeller and the impeller rod. now i basically have a rattle for a motor, im so mad... how can i get a new motor... any ideas?
__________________
enadeau12 is offline   Reply With Quote
Old 03-29-2009, 02:41 PM   #8
Aquarium Advice Addict
 
partypalooza5's Avatar
 
Join Date: Mar 2009
Location: Texas
Posts: 1,274
Send a message via AIM to partypalooza5 Send a message via Yahoo to partypalooza5
If it's just the impeller assembly itself, can't you just replace it? Instead of the entire motor?
__________________
75G FOWLR Build

partypalooza5 is offline   Reply With Quote
Old 03-29-2009, 03:03 PM   #9
Aquarium Advice Addict
 
krap101's Avatar
 
Join Date: Feb 2004
Location: Roscoe, IL
Posts: 6,084
Send a message via AIM to krap101
I think it would be more cost effective to buy a new filter rather than replace the motor. I'm not totally sure, but I don't think the motor actually has any moving parts.
__________________
~ Danny
krap101 is offline   Reply With Quote
Old 03-29-2009, 10:32 PM   #10
Aquarium Advice Activist
 
Join Date: Jan 2009
Location: Maine
Posts: 137
its all magnetics. i've temporarily fixed it. im soon upgrading to a canister. i just dont know what size canister to get. i have a 55 gallon with a pair of kribs, pair of rams, pair of pearl gourami's, one bn pleco and one geophagus jurapari. i want to go with an eheim. i just dont know what size. any opinions or guidance would be great, thanks in advance
__________________

__________________
enadeau12 is offline   Reply With Quote
Reply

Tags
filter

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
are Wet/dry filter & Mini-Reef Filter the same thing?? Bubble_B0y Freshwater & Brackish - General Discussion 1 08-26-2005 04:02 PM
Does Micron Filter Pad work well with HOB filter? ahboy22 Freshwater & Brackish - General Discussion 1 08-08-2005 09:41 PM
How to filter 200 gal. Would pond filter work? arowanaman420 General Hardware/Equipment Discussion 0 03-28-2005 11:05 PM
Filter Floss in an Eheim 2026 Canister Filter hforney General Hardware/Equipment Discussion 6 02-27-2005 02:28 AM
wet/dry filter vs penguin HOB filter SilviaGTO General Hardware/Equipment Discussion 4 03-19-2004 11:58 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 02:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.