Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 08-29-2013, 09:07 PM   #1
Aquarium Advice FINatic
 
FishBoy185's Avatar
 
Join Date: May 2013
Location: El paso
Posts: 633
Exclamation Help please?!

I bought a sunsun canister off of amazon and its not Priming!!! Ive pushed the blue button and filled the canister up with water and it still doesnt work. Ive pushed the button like 50 freakin times already!!!! I really need some help, do you think its because there is slack in the tubing? This thing is like an exercise trainer, can I please get some help??

Thank you very much in advance
__________________

__________________
125g South American..
FishBoy185 is offline   Reply With Quote
Old 08-29-2013, 09:27 PM   #2
Aquarium Advice Freak
 
Join Date: May 2013
Location: Bakersfield, California
Posts: 259
Are you giving it a second after priming? Also check the tubes. One is in one is out, make sure you have the out hooked up to the spray bar and the in hooked up to the intake tube. I did the same thing.
__________________

__________________
CalebZachary is offline   Reply With Quote
Old 08-29-2013, 09:32 PM   #3
Aquarium Advice Freak
 
Tandanus's Avatar
 
Join Date: Apr 2013
Location: I live in Adelaide Australia
Posts: 298
I have a primer on my filter also. It's not a sunsun (never heard of that brand). I don't fill the canister with water. As long as you don't have too much slack in your hoses as to cause kinks, it should not be a problem. All I do is press the prime button and wait. It usually takes a couple of minutes to get going. Did you give it a chance to see after you press it? When I first got mine, I thought the thing wasn't going to work but it is not instantaneous. If your instructions say to fill the canister then do so, otherwise empty it and try again. Give it a chance to get going. Good luck
__________________
Tandanus is offline   Reply With Quote
Old 08-30-2013, 10:23 AM   #4
Aquarium Advice FINatic
 
FishBoy185's Avatar
 
Join Date: May 2013
Location: El paso
Posts: 633
I finally got it primed last night after an hour. The water is crystal clear now
__________________
125g South American..
FishBoy185 is offline   Reply With Quote
Old 08-30-2013, 01:37 PM   #5
Aquarium Advice Freak
 
Join Date: May 2013
Location: Bakersfield, California
Posts: 259
When you do maintenance it should only take a few primes.
__________________
CalebZachary is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 05:50 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.