Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 10-11-2011, 12:53 PM   #1
Aquarium Advice Activist
revchristinejday's Avatar
Join Date: Mar 2011
Location: Johnson City, NY
Posts: 156
Help starting Fluval 405's

Well my new-to-me 125 gallon arrived Sunday and working through to about 10 PM yesterday I cleaned and converted the formerly salt tank to fresh water for my goldies. I threw out all the old salt media from my new-to-me 405 which had no manual. (Don't worry I also just transfered over from the old tanks with media intact a cascade 1000, 55 Aqueon and AC 70, gravel plants etc.) So being resource I found a manual online. However, after struggling with the lock and aqua stop valves I got them in the correct position. Did some priming with the start lever. Heard some bubbling and and switched them on nothing. Checked everything the manual said--no loops of hose, etc. Properly latched... So I unplugged them

So I think I have some water in them, but not primed enough.

What next? Do I have to detach everything and start over? Do I have to empty the canisters? Please advise.

Thank you!

revchristinejday is offline   Reply With Quote
Old 10-11-2011, 01:08 PM   #2
Aquarium Advice Addict
jcolon's Avatar
Join Date: Mar 2011
Location: Long Island NY
Posts: 3,470
Send a message via AIM to jcolon Send a message via Skype™ to jcolon
The impeller may not be pushed in all the way, happened to me when I did my first maintenance. I primed and Primed, but now water flowed. I removed the impeller cover, pushed down on the impeller and was good to go.
75g Planted Barbs Denison, BlackRuby, Tiger, Albino Tiger, Green Tiger, Cherry, Gold, Checkered, Odessa.
NonBarbs Cardinal, Neon, RummyNose, Bloodfin Tetras, Z. Danios. 1RTS. Amano, Bamboo, Ghost & RCS. 20g Long Shrimp Tank RCS, Tiger, Amano.
jcolon is offline   Reply With Quote

fluval, fluval 405, starting, val

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Smooth Tubing On My Fluval? CleverBs Freshwater & Brackish - General Discussion 4 09-18-2011 10:28 PM
Sump vs Fluval fx5 for Freshwater Franckler General Hardware/Equipment Discussion 1 09-02-2011 01:17 PM
fluval filters user404 Freshwater & Brackish - General Discussion 3 07-22-2011 07:53 PM
Hubert's Fluval Edge Build Thread! Hubert90 Freshwater & Brackish - Getting Started 8 07-10-2011 02:48 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:50 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.