Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 10-29-2013, 04:23 PM   #1
Aquarium Advice Apprentice
 
Markusroberts's Avatar
 
Join Date: Oct 2013
Posts: 39
Help with canister filter

Brought a tank off a friend brother and he gave me his canister filter he showed me how to set it up and I've done what he said I turned it on and it was all fine, then it started leaking from the top that screws in, I turned it off got rid of the water unscrewed it and checked the rubber bit and then put it on again and pushed down on it to make sure it was in, there's a clip on it that clicked to say its locks turned it on again and it happened again, the filter is a aquis 1000 I have looked on the internet and I can't find anything could anyone suggest an issue?
__________________

__________________
Markusroberts is offline   Reply With Quote
Old 10-29-2013, 05:01 PM   #2
Aquarium Advice Apprentice
 
Sam870o's Avatar
 
Join Date: Nov 2012
Location: Blasdell, Ny
Posts: 37
I don't have experience with that filter but my experiences with other canister filters a little Vaseline on the rubber seal helped stop any leaks I had.
__________________

__________________
Sam870o is offline   Reply With Quote
Old 10-29-2013, 10:24 PM   #3
Aquarium Advice Addict
 
Ian086's Avatar


 
Join Date: Nov 2012
Location: Drogheda, Ireland
Posts: 3,096
You could try what Sam suggested but personally I would just replace the O ring. Here is what you need, PLEASE double check that it's for your filter. I'm not sure if they ship to your part of the world. Email them. The O rings should be replaced every year or so, just to be safe. Generously rub some Vaseline between your fingers and run the rubber ring between your fingers. This keeps the rubber soft and stops it drying out and cracking, causing leaks. I would imagine that's what happened in your case, especially if it hadn't be changed/used in a while....

Aquis CF1000 / CF1200 Main Sealing Ring - Buy Aqua One with confidence at Aquarium Parts
__________________
Ian086 is offline   Reply With Quote
Old 10-30-2013, 09:31 AM   #4
Aquarium Advice Apprentice
 
Markusroberts's Avatar
 
Join Date: Oct 2013
Posts: 39
The filters only a couple of months old and it got emptied about 12 hours before I filled it, I'll try it out after I go get some
__________________
Markusroberts is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.