Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 04-04-2009, 07:23 AM   #1
Aquarium Advice Newbie
 
Join Date: Apr 2009
Posts: 4
Angry help with fluval 304

i've seen so many posts about problems with the primer and after reading through tons of threads, i finally got a GREAT flow. my issue now is leaking. i bought this filter 2nd hand. it had never been used before because he broke the primer handle for it. it seems to be leaking from either the back or from the hoses. i'm not sure if i'm missing a part for the hoses but they don't seem to fit very snug. i've notice the back doesn't seem to have a good seal either.

i've always wanted this filter but it seems to be more trouble than it's worth. any suggestions?
__________________

__________________
alex_g is offline   Reply With Quote
Old 04-04-2009, 08:34 AM   #2
SW REEF 18+ YEARS
Community Admin
 
melosu58's Avatar



Tank of the Month Award
 
Join Date: Oct 2004
Location: Virginia
Posts: 38,242
I dont have one but does it have any o-rings that are damaged.
__________________

__________________

SITE ADMINISTRATOR

You can view many of my fish and corals in my photo albums in my profile.

View my tank


AA Community Rules|AA TOS

Forums 101 - posting, accounts, basics
melosu58 is offline   Reply With Quote
Old 04-04-2009, 04:55 PM   #3
Aquarium Advice Newbie
 
Join Date: Apr 2009
Posts: 4
the o ring seems to be fine
__________________
alex_g is offline   Reply With Quote
Old 04-04-2009, 06:36 PM   #4
Aquarium Advice Newbie
 
Join Date: Apr 2009
Posts: 4
i figured it out. i bought it sencond hand and didn't see anything wrong with it. turns out there was a small crack in the lid that i didn't see when i inspected it. what a waste of time and money. i'm guessing there's no way to even salvage what i have.
__________________
alex_g is offline   Reply With Quote
Old 04-04-2009, 07:28 PM   #5
Aquarium Advice Addict
 
ezy33's Avatar
 
Join Date: Apr 2005
Location: San Francisco's Barbary Coast
Posts: 2,545
Send a message via ICQ to ezy33
Try searching the web I found several sites that carry parts. "fluval 304 parts"
__________________
Not one shred of evidence supports the notion that life is serious.
ezy33 is offline   Reply With Quote
Old 04-06-2009, 03:51 PM   #6
AA Team Emeritus
 
roka64's Avatar
 
Join Date: Mar 2006
Posts: 13,860
Send a message via AIM to roka64 Send a message via Yahoo to roka64
You can probably get a replacement lid. I have 2 fluvials and have never had a problem.
__________________
Age is relative, you are only as old as you act....of course, this works in reverse....

Questions loved, heeded advice greatly appreciated!

Vote for AA
Good reading about:
Nitrogen Cycle
Fishless Cycling
Need more help?
Articles
Acronym List

--Scott
roka64 is offline   Reply With Quote
Old 04-06-2009, 04:51 PM   #7
Aquarium Advice Newbie
 
Join Date: Apr 2009
Posts: 4
i would think the lid is would be the most expensive part of it
__________________

__________________
alex_g is offline   Reply With Quote
Reply

Tags
fluval, val

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluval 304 pitt420dude General Hardware/Equipment Discussion 14 04-22-2008 09:25 PM
Anyone Fluval 304? How to open it best? Tiffi General Hardware/Equipment Discussion 15 09-30-2005 02:37 PM
fluval 304 tbrock General Hardware/Equipment Discussion 3 05-31-2005 05:14 PM
prefilter on Fluval 304 tetrin General Hardware/Equipment Discussion 15 04-28-2005 11:07 PM
Problem with Fluval 304... westward13 General Hardware/Equipment Discussion 9 07-21-2004 09:25 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 12:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.