Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 02-03-2014, 05:51 AM   #1
Aquarium Advice Newbie
Join Date: Feb 2014
Location: Bournemouth, UK
Posts: 1
Hi - new to the forum and having filter issues!

Hi there,

I joined up to hopefully find some advice about my filter - I've had a 45 litre tank for 8 months (the AquaEl Classic 60 with AquaEl internal filter) and to begin with the filter worked brilliantly, shooting out a stream of bubbles and keep the water lovely and clear.

The first time I rinsed the filter sponge (in tank water) I noticed the bubbles coming out of the filter were not as strong as they had been before.

A couple of weeks later the bubbles had all but stopped and the filter wasn't keeping the tank as clean so I took the filter to pieces and carefully cleaned each part, (there was a bit of gunk on the impellor but not enough to cause problems I would have thought) and reassembled. Still the same issue, the filter just doesn't seem to be working as effectively.

The filter comes under three year warantee but I don't want to remove it and send back to the company because all the biological filter media will die - I do have an old filter I could use in the meantimefrom my old tank, a stingray one - but obviously this has not been used for 8 months and the filter sponge is a completely different shape/size.

Any advice would be gratefully received - my fish seem happy enough but I'm having to clean the tank more and more and it's a bit frustrating!



LeilaW is offline   Reply With Quote
Old 02-03-2014, 04:46 PM   #2
Aquarium Advice Addict
Join Date: Dec 2013
Location: West Yorkshire, England
Posts: 1,295
Sounds a big simple but did you replace the impeller cover after replacing the impeller. Did you clean down inside the impeller chamber, mine sometimes gets gummed up. I use a small bottle brush. My internal filter sometimes gets an air lock and I just wiggle it a bit and air comes rushing out follower by a normally strong flow. My internal filter also has a flow adjuster inside, not easily seen and I have slid the little cover across and not noticed. A cleaned filter, if correctly assembled, usually has a better flow rate. I hope one of these May be of some use. Good luck.
ScotJudd is offline   Reply With Quote


Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is having a fluorescent strip different than having a bulb? MC1973 Freshwater & Brackish - Planted Tanks 0 09-25-2012 03:28 AM
new to saltwater having issues ernie Saltwater & Reef - Getting Started 4 08-17-2011 11:35 AM
Very new, having some issues. Amartha Freshwater & Brackish - Unhealthy Fish 10 05-31-2011 11:38 PM
New planted 25g already having issues, need advice please Kilgore Freshwater & Brackish - Planted Tanks 9 02-23-2006 08:04 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 09:23 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.