Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 06-26-2016, 10:31 PM   #1
Aquarium Advice Newbie
 
Join Date: Jun 2016
Posts: 2
I need filter help please!

Hi everyone,
If you can give me advice on my filter you'd be a lifesaver. I have an API filter in a tank from Petco, all purchased new and used without incident until today. I moved my fish to clean the tank and when I plugged everything back in, the pump hums but doesn't create any motion in the water. I disassembled every part I could and wiped out a lot of gunk from the inside but still no dice- sound, which suggests the electricity is working, but nothing else. I'm not sure if there's something I can do to fix this or if I should get a new filter, in which case I'd also welcome advice on that. I've attached pictures of the offending apparatus- I'd like to figure it out asap so I don't have to worry about my fish!
Thank you so much!
Attached Thumbnails
Click image for larger version

Name:	api1.jpg
Views:	35
Size:	34.0 KB
ID:	287537   Click image for larger version

Name:	api2.jpg
Views:	32
Size:	32.3 KB
ID:	287538  

Click image for larger version

Name:	api3.jpg
Views:	34
Size:	34.5 KB
ID:	287539  
__________________

__________________
sideshowdachs is offline   Reply With Quote
Old 06-26-2016, 11:27 PM   #2
Aquarium Advice Addict
 
TMaier's Avatar



POTM Champion
Tank of the Month Award
 
Join Date: May 2016
Location: Concord, CA
Posts: 3,659
I need filter help please!

Sometimes you have to pour water into a filter to get it started. If there is an opening in the top where there is usually water try filling it up while the pump is plugged in.


Sent from my iPhone using Aquarium Advice
__________________

__________________
Old lady with tanks...
TMaier is offline   Reply With Quote
Old 06-26-2016, 11:30 PM   #3
Aquarium Advice Newbie
 
Join Date: Jun 2016
Posts: 2
My issue has been resolved, however it seems I can't delete my thread. But this is a great forum and I appreciate anyone who thought about this, and I hope I can contribute in the future!

(And in case it might help anyone else, my unit was missing a hook on the back that must have come out in cleaning. I'd made another makeshift one as well as all manner of repositioning and fidgeting so I'm not sure why only that exact specific angle made it work, but I'm glad it did!)
__________________
sideshowdachs is offline   Reply With Quote
Reply

Tags
filter, filter help

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just ordered an Eheim 2217 filter...Need/want some help please Shortyusa Freshwater & Brackish - General Discussion 4 07-31-2011 10:19 AM
New 55gal Hexagon - I need Filter & Fish help Please Freddy n Nigel Freshwater & Brackish - General Discussion 3 02-03-2009 12:53 AM
NEED HELP WITH FILTER CLEANING please lakersfreak General Hardware/Equipment Discussion 6 02-03-2006 08:19 PM
75 Bow Reef Tank....need a new filter, please help born2chill Saltwater Reef Aquaria 9 07-29-2005 03:00 AM
Do I need a filter on my 55 sw tank? Please Help me! b3noodles Saltwater Reef Aquaria 7 05-02-2005 11:00 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.