Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 04-01-2015, 06:26 PM   #1
Aquarium Advice Freak
 
giffmastaflex's Avatar
 
Join Date: Nov 2012
Posts: 423
Led light troubleshooting

I have a current satellite freshwater LED fixture and the other day it just flickered on and off then just turned off. Now when I plug it in it is not turning on. Anyone know what I can do to fix it and also how long of a warranty they have? I got it December 2014 so just over a year.


Sent from my iPhone using Aquarium Advice
__________________

__________________
giffmastaflex is offline   Reply With Quote
Old 04-01-2015, 06:31 PM   #2
Aquarium Advice Addict
 
Brookster123's Avatar
 
Join Date: Nov 2013
Location: Mass
Posts: 18,384
No offense.. have you changed the remote battery?

Sent from my SAMSUNG-SM-G900A using Aquarium Advice mobile app
__________________

__________________
I'm not really here... fell in the tank and my phone is just that smart
Brookster123 is offline   Reply With Quote
Old 04-01-2015, 06:57 PM   #3
Aquarium Advice Freak
 
giffmastaflex's Avatar
 
Join Date: Nov 2012
Posts: 423
I have it on a timer. The remote only changes the color and such and no offense taken. The remote can turn it on and off too but I don't think that it would cause it to flicker if it's already on


Sent from my iPhone using Aquarium Advice
__________________
giffmastaflex is offline   Reply With Quote
Old 04-01-2015, 08:22 PM   #4
Aquarium Advice Addict
 
Brookster123's Avatar
 
Join Date: Nov 2013
Location: Mass
Posts: 18,384
Could be a bad power supply??

Sent from my SAMSUNG-SM-G900A using Aquarium Advice mobile app
__________________
I'm not really here... fell in the tank and my phone is just that smart
Brookster123 is offline   Reply With Quote
Old 04-02-2015, 12:09 AM   #5
Aquarium Advice Freak
 
giffmastaflex's Avatar
 
Join Date: Nov 2012
Posts: 423
I tried multiple outlets. This really gets me mad because of how much it was


Sent from my iPhone using Aquarium Advice
__________________
giffmastaflex is offline   Reply With Quote
Old 04-02-2015, 02:01 PM   #6
Aquarium Advice Addict
 
Brookster123's Avatar
 
Join Date: Nov 2013
Location: Mass
Posts: 18,384
Not outlets but the actually power block in the cord. Have you contacted current? They have great customer service. Let me know...i actually have an extra power supply from when I had an issue last year.

Sent from my SAMSUNG-SM-G900A using Aquarium Advice mobile app
__________________
I'm not really here... fell in the tank and my phone is just that smart
Brookster123 is offline   Reply With Quote
Old 04-02-2015, 05:12 PM   #7
Aquarium Advice Activist
 
AJ_117's Avatar
 
Join Date: Jan 2015
Posts: 150
Quote:
Originally Posted by giffmastaflex View Post
I have a current satellite freshwater LED fixture and the other day it just flickered on and off then just turned off. Now when I plug it in it is not turning on. Anyone know what I can do to fix it and also how long of a warranty they have? I got it December 2014 so just over a year.


Sent from my iPhone using Aquarium Advice
Is there any visible signs of water inside the apparatus? Also, are ALL of the LEDs flickering or only a few? I've noticed that pretty much all of these LED systems have their LEDs connected in series; just like the old Christmas lights, if one goes out the next in the row goes out too.
__________________
AJ_117 is offline   Reply With Quote
Old 04-02-2015, 07:17 PM   #8
Aquarium Advice Freak
 
giffmastaflex's Avatar
 
Join Date: Nov 2012
Posts: 423
All flicker and all don't work and I don't see water, I see water marks on the underwater but there is a sheet of plexi-glass protecting it


Sent from my iPhone using Aquarium Advice
__________________
giffmastaflex is offline   Reply With Quote
Old 04-02-2015, 07:18 PM   #9
Aquarium Advice Freak
 
giffmastaflex's Avatar
 
Join Date: Nov 2012
Posts: 423
I'll contact current on Friday I think


Sent from my iPhone using Aquarium Advice
__________________
giffmastaflex is offline   Reply With Quote
Old 04-02-2015, 07:26 PM   #10
Aquarium Advice Activist
 
AJ_117's Avatar
 
Join Date: Jan 2015
Posts: 150
Quote:
Originally Posted by giffmastaflex View Post
All flicker and all don't work and I don't see water, I see water marks on the underwater but there is a sheet of plexi-glass protecting it


Sent from my iPhone using Aquarium Advice
Can you tell me any info on the power supply? How many volts and if its AC or DC?
__________________

__________________
AJ_117 is offline   Reply With Quote
Reply

Tags
led, light, trouble

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting your Saltwater Reef RO/DI System purewaterguy General Hardware/Equipment Discussion 0 02-23-2012 03:02 PM
CO2 troubleshooting runninwoof Freshwater & Brackish - Planted Tanks 3 07-09-2009 04:14 PM
Magnum 350 troubleshooting icon149 General Hardware/Equipment Discussion 11 01-16-2009 07:09 PM
hamilton technology fixture troubleshooting. Acer General Hardware/Equipment Discussion 5 10-13-2008 12:33 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 12:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.