Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion

Join Aquarium Advice Today
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
Old 09-28-2010, 06:05 AM   #1
Aquarium Advice Newbie
Join Date: Sep 2010
Posts: 1
Exclamation Magnum 350 issues!!

So I bought the 350 for my 44 gallon tank. It does a fantastic job (when it works) but within a month after I clean out the unit, the water flow slowly starts to decrease pressure and ends up with no output at all. The last time i cleaned it there was not hardly enough debris in it to cause this (I thought) i have carbon and the filter sleeve on it. Any ideas or recommendations? Im ready to go back to the classic side mounted filter.


MGiroux88 is offline   Reply With Quote
Old 09-28-2010, 07:20 AM   #2
AA Team Emeritus
Join Date: Oct 2006
Posts: 6,059
Moved to General Hardware/Equipment Discussion. You will get more answers here!

meegosh is offline   Reply With Quote
Old 09-28-2010, 11:45 AM   #3
Sliced Bread
neilanh's Avatar

Join Date: Dec 2006
Location: Northern Virginia
Posts: 8,482
Welcome to AA!

Something has to be clogging it up to cause the flow to reduce. You might not be able to see it in the filter as lots of debris is quite small, but something has to be clogging it.
In the DC Metro Area? Check out GWAPA and WAMAS
neilanh is offline   Reply With Quote
Old 09-30-2010, 11:26 AM   #4
Aquarium Advice Addict
WhiteDevil's Avatar
Join Date: Apr 2009
Location: 60118
Posts: 2,438
clean the intake tube inside the unit itself, the one that sits on the impeller and connects the lid to the media.
that piece has small outlets at the bottom with a 1/2" inlet at top. Every 2-3 cleanings of my mag350 require about 30 minutes of frustration to get it to work right again. its a nice filter when it works but other then that id only use it for a gravel vac or water polisher.
That's not a planted tank. That's a jungle with glass around it- MFDROOKIE Circa 2011
WhiteDevil is offline   Reply With Quote
Old 10-01-2010, 11:51 PM   #5
AA Team Emeritus
jsoong's Avatar

Join Date: Aug 2003
Location: Edmonton, Canada
Posts: 4,222
Yes, I have a Magnum 350 & it is a PITA to get working right ....

In addition to checking for clogs in the tubes, both inlet & outlet, (disassemble the whole thing & run a flexible brush through all the tubes), also check:
1. Any debris in the "sump" thing where the impeller sits. I had some sand in there once & that gummed up the impeller so there was no flow .... Also check for hard water deposits in the impeller magnet or the housing. <I had to soak the whole area with CLR every few months or the impeller will gum up.>
2. Is the impeller broken?
3. Is the output tube (inside the canister) lined up with the outlet hole in the lid? Is the o-ring worn? A missing or worn o-ring at that connection will drop the flow to nothing.
4. If you are running the water polishing cartridge, you need to clean that out every few days .... I can never get the Magnum to run for more than 2 or 3 days using the water polisher ....
5. Also check for airlock in the system ... the filter needs to be manually primed (my manual said to burp the canister to get rid of air ....) Also, loose o-rings may cause airlock & decrease the flow.

Anyways, the Magnum is so high maintenance that my sump is simplicity in comparison ...
80 gal FW with 30 gal DIY wet/dry/sump.
9 fancy golds, 1 hillstream loaches, 1 rubber-lip pleco (C. thomasi), 3 SAEs, small school of white cloud minnows, planted.
jsoong is offline   Reply With Quote

magnum, magnum 350

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnum 350 mint ranch General Hardware/Equipment Discussion 3 08-31-2008 06:37 PM
magnum 350 drummerj General Retailers 0 02-11-2007 11:54 PM
magnum 350 whitetiprs Saltwater Reef Aquaria 1 01-06-2005 02:03 PM
Magnum 350 talenzmeier Freshwater & Brackish - General Discussion 2 01-11-2004 09:58 PM
Magnum 350 / Just got it! Scottw68TN General Hardware/Equipment Discussion 8 09-24-2003 12:08 PM

» Photo Contest Winners

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:11 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.