Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 03-25-2013, 11:38 PM   #1
Aquarium Advice Activist
 
Mannydouhnut's Avatar
 
Join Date: Sep 2012
Posts: 120
My Mag Drive isnt Working

I have a mag drive 12 isn't pumping water. It does pump a little water but not even half of what its supposed to. It is making a loud shaking noise and is really starting to get on my nerves it doesn't even have enough flow to reach my tank it only goes up 5 feet. I don't think it's a priming problem as it is completely submerged and I even tilt it to get all the air out. I really need help and fast. Have taken apart the pump and put it back together over 5 times even if I do get it working once I unplug it it will stop and do the same thing. Please help if you have any input or have had similar problem let me know down below.
__________________
Mannydouhnut is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 06:54 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.