Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 10-01-2006, 07:24 PM   #1
Aquarium Advice Apprentice
 
Join Date: Jul 2005
Location: Salem Oregon
Posts: 23
Need XP3 Top Motor Cover

I recently purchased a "new" XP3 off ebay. However the Top cover has a crack where the quick disconnect hoses attach. This makes for a very hard time connecting the hoses. Rena does not sell the top cover as a replacement item. So if anyone out there has a dead XP3 but the top cover is in good condition I would sure like to purchase it.


Thanks all.

Bottom line...you get what you pay for.
__________________

__________________
rhansme is offline   Reply With Quote
Old 10-01-2006, 10:35 PM   #2
Aquarium Advice Addict
 
rkilling1's Avatar
 
Join Date: Dec 2005
Location: NE ohio
Posts: 2,245
Send a message via AIM to rkilling1
if it was new. then it is under warrenty and you should contact:

Contact Us

HOURS OF OPERATION:
8:00 AM - 5:00 PM Eastern Time (Monday through Friday)

Product/Technical Support: (800) 847-0659

Mailing Address:
Aquarium Pharmaceuticals, Inc.
PO Box 218
Chalfont, PA 18914-0218
Main Office: (215) 822-8181

You can also contact us via email or by using our Help Desk for questions or product warranty.

http://www.rena.net/en_us/contact.asp
__________________

__________________
rkilling1 is offline   Reply With Quote
Old 10-02-2006, 12:25 AM   #3
Aquarium Advice Apprentice
 
Join Date: Jul 2005
Location: Salem Oregon
Posts: 23
I would like to send the unit back, however this was not purchased from a retail business. I purchased it from an individual on ebay who stated that the item was "new". I have talked to Rena about purchasing the top cover and was told that it is not available. I assumed that this would be a common item, as the area that is cracked is vulnerable to this.
I'm sure that the previous owner was aware of this and did not mention this in the auction description. I left appropriate feedback and accepted my item. So I am looking for the top cover only. I am sure that someone out there has a dead XP3 that would like to part with the top cover. If not, I will find a way to fix it myself. I am currently just placing a piece of shipping tape underneath and it seems to provide enough support that I can take the hoses off and on for maintainance. Super Glue will not work on this type of plastic. It just peels off after drying. I will have to try something else if no one can help.
__________________
rhansme is offline   Reply With Quote
Old 10-02-2006, 02:29 PM   #4
Aquarium Advice Addict
 
Join Date: Dec 2003
Location: Nebraska, USA
Posts: 6,703
bought off eBay? start the 'complaint' process and try to make the seller 'make good' on it.

otherwise, look on ebay for a used one or one that's got a broken bottom.
__________________
Former advisor and planted tank geek...life's moved on though.
malkore is offline   Reply With Quote
Old 10-05-2006, 02:42 AM   #5
Aquarium Advice Apprentice
 
Join Date: Jul 2005
Location: Salem Oregon
Posts: 23
ttt
__________________
rhansme is offline   Reply With Quote
Reply

Tags
cover, motor, oto, xp3

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Filter Motor Karegg Freshwater & Brackish - Getting Started 1 02-23-2009 07:37 PM
Do these jump??? Do I really need to cover the top? weekf Saltwater Reef Aquaria 14 10-25-2006 03:23 PM
Question about how to cover the top of my tank. mnestroy Saltwater Reef Aquaria 7 03-31-2006 08:26 PM
XP3, pebble in motor sound??? Electrobes General Hardware/Equipment Discussion 18 10-22-2003 01:59 PM
Moss-like plant to cover top of driftwood? lmw80 Freshwater & Brackish - Planted Tanks 3 09-25-2003 10:41 AM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 03:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.