Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 10-30-2007, 10:59 AM   #1
Aquarium Advice Addict
 
newfound77951's Avatar
 
Join Date: Feb 2006
Location: St Petersburg FL
Posts: 2,114
new XP3...air in filter

I know this has probably been asked a zillion times now.... I just set up my new XP3 last night on my 55g. There seems to be a lot of air bubbles in the filter under the intake, and they cause a bit of impeller noise as well as gurgling-water noise. Granted, I can't hear it over the noise of the SW tank's skimmer unless I put my head in the stand of the 55, but I thought these things were supposed to be essentially silent....any tricks to get rid of that air? I did try rocking the filter around to bleed out some of the air and that helped a little. Otherwise it seems to run fine and the rainbows are loving the current.
__________________

__________________
newfound77951 is offline   Reply With Quote
Old 10-30-2007, 11:52 AM   #2
Aquarium Advice Freak
 
Join Date: Jan 2007
Location: Marietta, GA
Posts: 487
Send a message via AIM to Atl300zx
when i set mine up, i filled up the filter completely to the point when i put the lid on, it slightly overflowed. Then i used the techinique described in the manual for priming the lines using the funnel. Then i just plugged it in. After a few seconds mine was/is completely silent and hasnt given me any trouble.
__________________

__________________
55 Gallon Tank Log
Atl300zx is offline   Reply With Quote
Old 10-30-2007, 02:27 PM   #3
Aquarium Advice Addict
 
newfound77951's Avatar
 
Join Date: Feb 2006
Location: St Petersburg FL
Posts: 2,114
Yeah, I think I have an air problem, not an impeller problem. The filter had only been on for about 10 hrs when I listened this AM so I'll be interested to see what it is doing when I get home tonight.

BTW, has anyone actually managed to get the hoses on 2"?? how the heck did you do it? I know I'm a weakling, but really.....
__________________
newfound77951 is offline   Reply With Quote
Old 10-30-2007, 10:25 PM   #4
Aquarium Advice Freak
 
Join Date: Jan 2006
Location: Western New York
Posts: 391
I also believe you have a air lock problem. Rockin the filter a little more tonight should solve it.

Stick the end of the hose into very hot water for a few seconds.
Softens them up, and they slide right on.
__________________
TwoHobbies is offline   Reply With Quote
Old 10-30-2007, 11:04 PM   #5
Aquarium Advice Addict
 
Join Date: Nov 2006
Posts: 2,254
You can also try to reprime it by taking the lid off and putting it back on a couple times. This tends to get a bit more water into the filter each time, pushing the water out.
__________________

theotheragentm is offline   Reply With Quote
Old 10-31-2007, 09:02 PM   #6
src
Aquarium Advice Freak
 
Join Date: Jun 2006
Location: Richmond, Virginia
Posts: 476
I frequently get a lot of air trapped in one of my XP2's (it has a skimmer intake). The simple fix is to unplug the filter and release ONE of the latches holding the top on. The air will escape, replaced by water from the hoses. Once the body is full again (you might get a trickle of water), re-fasten the latch.

Takes about 5 seconds total.
__________________
src is offline   Reply With Quote
Old 11-01-2007, 11:56 AM   #7
Aquarium Advice Addict
 
newfound77951's Avatar
 
Join Date: Feb 2006
Location: St Petersburg FL
Posts: 2,114
Thanks everyone! great advice. Hopefully one or all of these will fix the problem. I didn't get home until late last night so didn't get a chance to mess with the filter at all.
__________________

__________________
newfound77951 is offline   Reply With Quote
Reply

Tags
air, filter, xp3

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xp3 air bubbles shayfish General Hardware/Equipment Discussion 14 03-17-2007 07:58 PM
What filter media do you use in your xp3? niks93gt Freshwater & Brackish - General Discussion 7 01-04-2007 02:35 AM
XP3 filter PauloSilva Freshwater & Brackish - General Discussion 8 04-08-2006 11:57 AM
Those here with XP3 filter! xcuter General Hardware/Equipment Discussion 4 04-08-2005 11:48 AM
Rena-Filter XP3 taz291819 Saltwater Reef Aquaria 1 03-31-2005 04:26 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 01:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.