Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 05-28-2011, 11:49 PM   #11
Aquarium Advice Freak
 
Join Date: May 2011
Location: tampa
Posts: 331
If it doesn't spin it's the motor so it will need a new filter
__________________

__________________
thras is offline   Reply With Quote
Old 05-28-2011, 11:51 PM   #12
Aquarium Advice Addict
 
mudraker's Avatar
 
Join Date: May 2009
Location: Alaska
Posts: 1,652
Have you tried actually taking the filter apart, cleaning the impeller, housing and all?

A lot of times hair and other crap can get wrapped around the impeller, or sometimes they just fill with up with normal detrius and will start pumping again once the impeller is clean and the hole where the impeller goes is free of debris.
__________________

__________________
mudraker is offline   Reply With Quote
Old 05-28-2011, 11:52 PM   #13
Aquarium Advice Addict
 
mudraker's Avatar
 
Join Date: May 2009
Location: Alaska
Posts: 1,652
thras beat me to the punch, but its good advice.
__________________
mudraker is offline   Reply With Quote
Old 05-28-2011, 11:54 PM   #14
Aquarium Advice Addict
 
Deckape's Avatar
 
Join Date: Mar 2011
Posts: 1,567
Quote:
Originally Posted by thras
Might be a little late but I have experience with these filters I would try piling the impeller out and take a q tip or 5 and clean out the inside where the magnet gos it gets gunk in it sometimes and clean the impeller shaft then put a little bit of water in and plug it in after u install just the impeller and see if it's spinning if it is put it back together and prime the filter then stick the media back in
Thanks! I appreciate the back up
__________________
Smile, it makes folks think that you're up to something.

http://www.aquariumadvice.com/forums...ml#post1456422
Deckape is offline   Reply With Quote
Old 05-28-2011, 11:57 PM   #15
Aquarium Advice FINatic
 
Join Date: May 2011
Location: Arizona
Posts: 746
Wow. Thank you guys for the quick replies and help!

... I tried cleaning Thras with the q tip, there was very little gunk, and the impellar is spinning, but not sunking in water, idk why...
__________________
I CAME BACK TO CONTINUE TO SEVER THE CORD
Esoteric Backbone is offline   Reply With Quote
Old 05-29-2011, 12:03 AM   #16
Aquarium Advice Freak
 
Join Date: May 2011
Location: tampa
Posts: 331
Only thing I can say to do at this point is to keep adding water I add it till it comes out the filter and keep adding and did the base of the intake seat all the way down they can be a little stubborn sometimes
__________________
thras is offline   Reply With Quote
Old 05-29-2011, 12:04 AM   #17
Aquarium Advice Freak
 
Join Date: May 2011
Location: tampa
Posts: 331
And try this all without the blue filter pad in it then add after it kicks back on easier that way
__________________
thras is offline   Reply With Quote
Old 05-29-2011, 12:06 AM   #18
Aquarium Advice FINatic
 
Join Date: May 2011
Location: Arizona
Posts: 746
Ok ill try it.
__________________
I CAME BACK TO CONTINUE TO SEVER THE CORD
Esoteric Backbone is offline   Reply With Quote
Old 05-29-2011, 12:11 AM   #19
Aquarium Advice Addict
 
Deckape's Avatar
 
Join Date: Mar 2011
Posts: 1,567
Quote:
Originally Posted by GrimmGoby
Ok ill try it.
My damage control advice stands if all else fails. Keep us informed on the outcome please
__________________
Smile, it makes folks think that you're up to something.

http://www.aquariumadvice.com/forums...ml#post1456422
Deckape is offline   Reply With Quote
Old 05-29-2011, 12:14 AM   #20
Aquarium Advice Freak
 
Join Date: May 2011
Location: tampa
Posts: 331
And yes I would agree with ducktape to put ur media in the tank or In a baggy
__________________

__________________
thras is offline   Reply With Quote
Reply

Tags
filtration

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New filtration Gsxrownr General Hardware/Equipment Discussion 2 05-21-2011 10:33 PM
filtration m-man Cichlid Discussion 10 08-22-2008 10:55 PM
Need filtration help please 30searay Freshwater & Brackish - Planted Tanks 4 07-21-2008 12:24 AM
Filtration issues, or lack-there-of filtration... penelope Freshwater & Brackish - Getting Started 9 03-02-2008 08:22 PM
Enough filtration??? Chipie Freshwater & Brackish - General Discussion 1 03-03-2007 12:52 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 04:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.