Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 08-30-2009, 11:16 PM   #1
Aquarium Advice FINatic
 
jessicasmarine's Avatar
 
Join Date: May 2009
Location: MCRD PI, SC
Posts: 660
Octopus NW 150

I just bought a new Octopus 150. Just wondering if anyone has used it and if there will be any mods neccesary, as well as pro/cons.
__________________

__________________
-Zack
I blame Craig AND his stupid List.
jessicasmarine is offline   Reply With Quote
Old 08-30-2009, 11:29 PM   #2
Aquarium Advice Addict
 
thominil's Avatar


 
Join Date: Jul 2008
Location: In the middle of the corn....
Posts: 2,773
Neilan has that same model on his 72g bf, you can just shoot him a pm and ask.
__________________

__________________
~Thom
Any questions? Feel free to PM me.
Hitchhikers on live rock? http://www.xtalworld.com/Aquarium/hitchfaq.htm
Like someone's post? Show some appreciation with the reputation button!
thominil is offline   Reply With Quote
Old 08-30-2009, 11:35 PM   #3
Aquarium Advice FINatic
 
jessicasmarine's Avatar
 
Join Date: May 2009
Location: MCRD PI, SC
Posts: 660
thankx
__________________
-Zack
I blame Craig AND his stupid List.
jessicasmarine is offline   Reply With Quote
Old 08-31-2009, 01:04 AM   #4
Sliced Bread
 
neilanh's Avatar


 
Join Date: Dec 2006
Location: Northern Virginia
Posts: 8,482
I haven't modded mine at all, and like Thom said I'm running it and love it. There are a ton of mods you can do to it, if you want (google it, there's tons of info), but I've not found a need personally.

Set it up, after about a week of break-in and getting it tuned mine was running great and I've not yet had a single problem with it.
__________________
~Neilan
In the DC Metro Area? Check out GWAPA and WAMAS
neilanh is offline   Reply With Quote
Old 09-08-2009, 04:56 PM   #5
Aquarium Advice FINatic
 
jessicasmarine's Avatar
 
Join Date: May 2009
Location: MCRD PI, SC
Posts: 660
Just turned on my skimmer for the first time and the pump is creating no suction. Its running because the needlewheel impeeler is quite loud. But its not pushing much water or any air. Any thoughts.
__________________
-Zack
I blame Craig AND his stupid List.
jessicasmarine is offline   Reply With Quote
Old 09-08-2009, 05:03 PM   #6
Aquarium Advice Addict
 
thominil's Avatar


 
Join Date: Jul 2008
Location: In the middle of the corn....
Posts: 2,773
Is the impeller seated in the pump right?
__________________
~Thom
Any questions? Feel free to PM me.
Hitchhikers on live rock? http://www.xtalworld.com/Aquarium/hitchfaq.htm
Like someone's post? Show some appreciation with the reputation button!
thominil is offline   Reply With Quote
Old 09-08-2009, 05:04 PM   #7
Aquarium Advice FINatic
 
jessicasmarine's Avatar
 
Join Date: May 2009
Location: MCRD PI, SC
Posts: 660
looks like it
__________________
-Zack
I blame Craig AND his stupid List.
jessicasmarine is offline   Reply With Quote
Old 09-08-2009, 05:06 PM   #8
Sliced Bread
 
neilanh's Avatar


 
Join Date: Dec 2006
Location: Northern Virginia
Posts: 8,482
Blow in the air inlet tube while it's running. Sounds crazy, but I had to do this whenever I first started it up for a while until the unit got broken in. Blow into the tube to get the venturi started up, and off it'll go.

I don't know for sure what happened, eventually mine just stopped needing me to do this on it's own.
__________________
~Neilan
In the DC Metro Area? Check out GWAPA and WAMAS
neilanh is offline   Reply With Quote
Old 09-08-2009, 05:09 PM   #9
Aquarium Advice Addict
 
thominil's Avatar


 
Join Date: Jul 2008
Location: In the middle of the corn....
Posts: 2,773
I would just look it over and play around with the impeller, make sure nothing is bent. Check all the "O" rings as well. Inspect the whole pump, if you find nothing wrong, my question lies to the motor in which case you may need to call the manufacturer and who you ordered it from.

LOL, I think Neilan solved it.
__________________
~Thom
Any questions? Feel free to PM me.
Hitchhikers on live rock? http://www.xtalworld.com/Aquarium/hitchfaq.htm
Like someone's post? Show some appreciation with the reputation button!
thominil is offline   Reply With Quote
Old 09-08-2009, 05:12 PM   #10
Aquarium Advice FINatic
 
jessicasmarine's Avatar
 
Join Date: May 2009
Location: MCRD PI, SC
Posts: 660
LOL I did the same thing at first until I felt stupid then decided to ask yall. Gues I wasnt to stupid. Let the blowing commence. Let you know the outcome if I dont hyperventilate
__________________

__________________
-Zack
I blame Craig AND his stupid List.
jessicasmarine is offline   Reply With Quote
Reply

Tags
octopus

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Reef Octopus NW-150 Protein Skimmer Mesh Modded ryshark Archive 1 09-30-2009 03:31 AM
Octopus needelwheel 150 skimmer question vietcu General Hardware/Equipment Discussion 1 02-17-2008 11:08 PM
Octopus? gooyferret Saltwater Reef Aquaria 9 09-05-2003 02:46 AM
Octopus Saltwater Reef Aquaria 2 01-25-2003 11:55 AM
octopus Vicshaw Saltwater Reef Aquaria 2 01-04-2003 05:04 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.