Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 05-13-2008, 11:03 PM   #11
Aquarium Advice Addict
 
Fishyfanatic's Avatar
 
Join Date: Dec 2004
Location: Illinois
Posts: 11,964
Definitely keep an eye on it. One of the biggest complaints (and I see it a LOT) is the leaking water on the Renas. I hope it gets taken care of. Keep us posted.
__________________

__________________
Vote for Aquarium Advice

29 Gallon Lake Malawi Fry
55 Gallon Community
150 Gallon Lake Malawi Cichlid
Fishyfanatic is offline   Reply With Quote
Old 05-14-2008, 02:35 AM   #12
Aquarium Advice Regular
 
esaone's Avatar
 
Join Date: Feb 2005
Location: WV
Posts: 79
I have four and they are perfect.
Nearly silent and all I've ever had to do was replace fine pads and rings.
__________________

__________________
esaone is offline   Reply With Quote
Old 05-14-2008, 09:41 AM   #13
Aquarium Advice Addict
 
plecoperson's Avatar
 
Join Date: Apr 2006
Location: Evanston, Illinois
Posts: 1,245
It seems like most of the Renas work well, but it doesn't seem uncommon for them to be noisy and/or leak. I've heard the same reports with Fluvals; some love them and some don't.

I think the biomedia made it through OK; I had just cleaned the filter a coupla weeks ago so it wasn't too funky. I put the biomedia in a bag in my HOB, and the tank is sparkly and the fish are happy. Will be testing every couple days to make sure there's no drama.

Thanks to everyone for your support and comments, and I'll report back when the new impeller is installed!
__________________
-Lisa

Remember that Darwin was mostly right!
plecoperson is offline   Reply With Quote
Old 05-20-2008, 11:01 PM   #14
Aquarium Advice Addict
 
plecoperson's Avatar
 
Join Date: Apr 2006
Location: Evanston, Illinois
Posts: 1,245
Smile

Awright, I replaced the impeller and ran the filter a couple days empty. All was well, so I refilled the media today and it's humming along very nicely. And quietly. And no leaking.

I did read somewhere that one should not remove the impeller unless it's truly fouled up, and I had been taking it out periodically to rinse off slime. That repeated removal and re-insertion could have been what caused the impeller to wear prematurely.

I hope so, 'cause when it's running well I almost feel like trying again at our relationship...I just have to learn to trust again....[sniff]
__________________
-Lisa

Remember that Darwin was mostly right!
plecoperson is offline   Reply With Quote
Old 05-20-2008, 11:15 PM   #15
AA Team Emeritus
 
An t-iasg's Avatar


 
Join Date: Aug 2003
Location: Criders Corners, PA
Posts: 9,891
Hopefully the tides are turning and you'll have smooth sailing again - you and your Filstar!

Glad to hear it's working well now!
__________________







An t-iasg is offline   Reply With Quote
Old 05-20-2008, 11:37 PM   #16
Sliced Bread
 
neilanh's Avatar


 
Join Date: Dec 2006
Location: Northern Virginia
Posts: 8,482
Good job figuring out the problem and correcting it.
__________________

__________________
~Neilan
In the DC Metro Area? Check out GWAPA and WAMAS
neilanh is offline   Reply With Quote
Reply

Tags
filstar, rena

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rena Filstar xp3 StephanieNC General Hardware/Equipment Discussion 8 09-07-2009 10:29 AM
Rena XP Filstar black hills tj General Hardware/Equipment Discussion 6 10-23-2008 05:51 PM
Rena Xp3 Filstar moejoephd General Hardware/Equipment Discussion 2 09-05-2004 01:09 PM
Rena Filstar alancsilver General Hardware/Equipment Discussion 2 05-01-2004 08:32 PM
Fluval vs Rena Filstar Chueyboy General Hardware/Equipment Discussion 3 12-28-2003 03:26 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.