Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 02-15-2009, 06:12 PM   #11
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Ruadh
Thank you very much.
I just pulled the impeller out of it's housing and cleaned everything.
I think it's OK now.

Charles
__________________

__________________
cbwmn is offline   Reply With Quote
Old 02-15-2009, 06:24 PM   #12
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Nah - It just started spitting air again.
I think I may need a new impeller assy.
Charles
__________________

__________________
cbwmn is offline   Reply With Quote
Old 02-15-2009, 10:13 PM   #13
Aquarium Advice Activist
 
Join Date: Sep 2008
Posts: 188
Did you check all your gaskets?
__________________
Ruadh is offline   Reply With Quote
Old 02-16-2009, 01:54 AM   #14
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Ruadh
I just opened it up again.
I can only see two gaskets, one rectangular shaped around the perimeter of the canister and one about 4" diameter around the impeller assy.
While messing with the 4" one, it started to come out. Is it supposed to be O-ring shaped or one piece of soft foam rubber inserted into the groove?
If it's suposed to be an O-ring, that may be my problem.
I'll call API in the morning and ask.
Thanks again for all of your help.
Charles
__________________
cbwmn is offline   Reply With Quote
Old 02-16-2009, 07:33 PM   #15
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Ruadh
I went to an aut parts store and bought some o-rings for the quik-disconnect. That slowed the "burping air" somewhat.
Tomorrow I may go get some that are the same diameter but a little fatter.

Do you think I could use vinyl tubing to replace the hoses?
I don't want to harm the fish.
Thank again
Charles
__________________
cbwmn is offline   Reply With Quote
Old 02-16-2009, 08:15 PM   #16
Aquarium Advice Activist
 
Join Date: Sep 2008
Posts: 188
Vinyl tube is fine. That's what I've been using.

You problem is sure a persistant one.
How old is your filter?

I'm not sure what to say now. This is, of course up to you, but when I put mine together the last time, I used a little bit of lipsil smeared around the seal. Lipsil is just real thick petrolium jelly and as such you need to make sure none gets inside the filter. I just got the gasket "wet" and all was fine.
This type of thing might seal the case.
__________________
Ruadh is offline   Reply With Quote
Old 02-17-2009, 10:03 AM   #17
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Ru
The filter is 8 mos old.
I'm gonna call API today.
They're going to try & sell me hoses, impellers, etc.
May need the ompeller tho;
Thank you
Charles
__________________
cbwmn is offline   Reply With Quote
Old 02-26-2009, 10:54 PM   #18
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Hey all
After conversing with Ruad several times, I decided to change the hoses.
I went to HD, bought the correct size of vinyl tubing, and replaced the hoses. I used petroleum jelly to lube the ends of the hose.
It worked. No more spitting air.
Spitting air wasn't harmful to the fish, but it was irritating.
I still don't know where the air leak was. The old hoses looked fine to me.
Thanks again Ruad

Charles
__________________
cbwmn is offline   Reply With Quote
Old 02-27-2009, 12:29 AM   #19
Aquarium Advice Activist
 
Join Date: Sep 2008
Posts: 188
You're most welcome, but it's Ruadh, not Ruad.
Pronounced Roo-ah. Scottish Gaelic
__________________
Ruadh is offline   Reply With Quote
Old 02-27-2009, 07:47 PM   #20
Aquarium Advice Freak
 
Join Date: Dec 2008
Location: El Paso, TX
Posts: 201
Ruadh

Sorry, I had another "SENIOR MOMENT".
Hoses were switched.
I've 4 degenerated vertebrae in my back. And it affects everything.
Have trouble walking, thinking, talking, etc.
I'm going to an Ortopedist Monday.

Charles
__________________

__________________
cbwmn is offline   Reply With Quote
Reply

Tags
bubble, bubbles, rena

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Pumping Xenia weemanpow3 Saltwater Reef Aquaria 8 09-03-2006 10:13 PM
Pumping Xenia JohnNLuc Saltwater Reef Aquaria 8 01-30-2005 01:34 PM
Best pumping options shawmutt General Hardware/Equipment Discussion 10 01-05-2005 04:38 AM
xenia not pumping blackthunda77 Saltwater Reef Aquaria 4 06-21-2004 10:03 PM
Pumping Xenia WarOrks15 Saltwater Reef Aquaria 7 05-04-2004 05:19 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 04:11 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.