Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 08-15-2013, 06:57 AM   #1
Aquarium Advice FINatic
 
Canary bird's Avatar
 
Join Date: Jul 2013
Location: Tenerife, ES
Posts: 586
Rena xp3

I've had this xp3 for 2 weeks , without a problem... Yesterday I noticed 4 baby fish in there so I turned it off emptied the baskets, rescued the fish , put it all back together , primed it and plugged it back in, and now it seems to be playing up , the water level keeps dropping inside , like its filling up with air ! When I switch it off it fills back up with water and blows all the air out of the spray bar, so this morning I filled it up by hand then put the lid back on (water everywhere!) and it seems fine, has anyone else had this problem ? Also the water isn't right to the top inside the canister is that normal too ? ( first canister filter I've owned)



Click image for larger version

Name:	image-464044999.jpg
Views:	89
Size:	127.8 KB
ID:	192297

Please tell me this is normal water level ...

Thanks
__________________

__________________
I Love Anglefish
Canary bird is offline   Reply With Quote
Old 08-15-2013, 08:24 AM   #2
Aquarium Advice FINatic
 
Tx Oscar Lover's Avatar
 
Join Date: Jul 2013
Posts: 694
Quote:
Originally Posted by Canary bird View Post
I've had this xp3 for 2 weeks , without a problem... Yesterday I noticed 4 baby fish in there so I turned it off emptied the baskets, rescued the fish , put it all back together , primed it and plugged it back in, and now it seems to be playing up , the water level keeps dropping inside , like its filling up with air ! When I switch it off it fills back up with water and blows all the air out of the spray bar, so this morning I filled it up by hand then put the lid back on (water everywhere!) and it seems fine, has anyone else had this problem ? Also the water isn't right to the top inside the canister is that normal too ? ( first canister filter I've owned)

Please tell me this is normal water level ...

Thanks
I actually just purchasrd two of these. & after a few days one of mine was leaking from the electrical cord. I'm not sure what caused it. But I sent it back and am getting another one for free. Hopefully it doesn't happen again. But the air thing was happening to me as well. I hope these filters turn out to be good products.
__________________

__________________
Tx Oscar Lover is offline   Reply With Quote
Old 08-15-2013, 08:26 AM   #3
Aquarium Advice FINatic
 
Canary bird's Avatar
 
Join Date: Jul 2013
Location: Tenerife, ES
Posts: 586
Quote:
Originally Posted by Tx Oscar Lover View Post

I actually just purchasrd two of these. & after a few days one of mine was leaking from the electrical cord. I'm not sure what caused it. But I sent it back and am getting another one for free. Hopefully it doesn't happen again. But the air thing was happening to me as well. I hope these filters turn out to be good products.
It's amazing when it's working, just hope by filling the canister by hand worked ! Seems ok at the moment :/
__________________
I Love Anglefish
Canary bird is offline   Reply With Quote
Old 08-15-2013, 08:28 AM   #4
Aquarium Advice FINatic
 
Tx Oscar Lover's Avatar
 
Join Date: Jul 2013
Posts: 694
Quote:
Originally Posted by Canary bird View Post

It's amazing when it's working, just hope by filling the canister by hand worked ! Seems ok at the moment :/
I agree. When working lol. I had two in a 175 gallon tank & it cleared it up so fast. Just disappointed it messed up. I hope yours continues to work.
__________________
Tx Oscar Lover is offline   Reply With Quote
Old 08-15-2013, 09:36 AM   #5
Aquarium Advice FINatic
 
Canary bird's Avatar
 
Join Date: Jul 2013
Location: Tenerife, ES
Posts: 586
I have also just realised it didn't do this when I had the power head on , I switched to the spray bar only a couple of days ago !
__________________
I Love Anglefish
Canary bird is offline   Reply With Quote
Old 08-15-2013, 10:30 AM   #6
Aquarium Advice Addict
 
FishCr8zy's Avatar

POTM Champion
 
Join Date: May 2013
Location: New Jersey, USA
Posts: 2,458
Send a message via Skype™ to FishCr8zy
Quote:
Originally Posted by Canary bird View Post
I've had this xp3 for 2 weeks , without a problem... Yesterday I noticed 4 baby fish in there so I turned it off emptied the baskets, rescued the fish , put it all back together , primed it and plugged it back in, and now it seems to be playing up , the water level keeps dropping inside , like its filling up with air ! When I switch it off it fills back up with water and blows all the air out of the spray bar, so this morning I filled it up by hand then put the lid back on (water everywhere!) and it seems fine, has anyone else had this problem ? Also the water isn't right to the top inside the canister is that normal too ? ( first canister filter I've owned)

Please tell me this is normal water level ...

Thanks
The water level seems fine as that is about the same level of water in my xp4. So your saying when you turn it on, air bubbles just keep coming out?
And when you turn it off, is the lever down or up? And when you prime it, is the lever down or up?
__________________
It wasnít until 1853 in London when aeration and filtration of water was understood, that people
were able to keep fish as indoor pets.

FishCr8zy is offline   Reply With Quote
Old 08-15-2013, 10:37 AM   #7
Aquarium Advice FINatic
 
Canary bird's Avatar
 
Join Date: Jul 2013
Location: Tenerife, ES
Posts: 586
Quote:
Originally Posted by FishCr8zy View Post

The water level seems fine as that is about the same level of water in my xp4. So your saying when you turn it on, air bubbles just keep coming out?
And when you turn it off, is the lever down or up? And when you prime it, is the lever down or up?
Yes the air comes out but only for a few seconds, then it seems to run fine and then the Level starts to drop..
When I first primed it I did it with the lever down in the locked position ... Note to self re read instructions it will save you time ... But when I did it yesterday I did it with the lever up then it self primed !
It seems to be ok, at the moment, I think there could be an air lock somewhere , but it seems to have started weird behaviour since I changed to the spray bar !
__________________
I Love Anglefish
Canary bird is offline   Reply With Quote
Old 08-15-2013, 10:48 AM   #8
Aquarium Advice Addict
 
FishCr8zy's Avatar

POTM Champion
 
Join Date: May 2013
Location: New Jersey, USA
Posts: 2,458
Send a message via Skype™ to FishCr8zy
Quote:
Originally Posted by Canary bird View Post

Yes the air comes out but only for a few seconds, then it seems to run fine and then the Level starts to drop..
When I first primed it I did it with the lever down in the locked position ... Note to self re read instructions it will save you time ... But when I did it yesterday I did it with the lever up then it self primed !
It seems to be ok, at the moment, I think there could be an air lock somewhere , but it seems to have started weird behaviour since I changed to the spray bar !
The lever should be up when primed then you push it down and then it primes itself. Also when you take the lid off the lever should be down. And when the level drops, does it stop dropping at the water level in the pic above?
__________________
It wasnít until 1853 in London when aeration and filtration of water was understood, that people
were able to keep fish as indoor pets.

FishCr8zy is offline   Reply With Quote
Old 08-15-2013, 10:54 AM   #9
Aquarium Advice FINatic
 
Canary bird's Avatar
 
Join Date: Jul 2013
Location: Tenerife, ES
Posts: 586
Quote:
Originally Posted by FishCr8zy View Post

The lever should be up when primed then you push it down and then it primes itself. Also when you take the lid off the lever should be down. And when the level drops, does it stop dropping at the water level in the pic above?
Yes I now know after re reading the manual
The level in the picture is the highest, it drops half way down the top basket, that's why I turned it off last night I was worried it would blow up or something, but so far today it's been ok ? It has dropped a little lower than the picture but I think it's ok for now !
__________________
I Love Anglefish
Canary bird is offline   Reply With Quote
Old 08-15-2013, 01:19 PM   #10
Aquarium Advice Addict
 
bshenanagins's Avatar
 
Join Date: Feb 2013
Posts: 1,583
Quote:
Originally Posted by Canary bird View Post

Yes I now know after re reading the manual
The level in the picture is the highest, it drops half way down the top basket, that's why I turned it off last night I was worried it would blow up or something, but so far today it's been ok ? It has dropped a little lower than the picture but I think it's ok for now !
I too have had my share of issues with Xp's but they great once you get past them. Your dropping water level means that somewhere along the intake there is air getting in. Usually at the top of the connection somewhere so make sure the links on the intake are pushed together tightly, And of course the priming cap. Here's a hint to raise your water level. Open one of the clips very slowly until you hear a hissing, you will see the water level start to rise. Once it hits the top of the filter, quick close the clip. Water level issue solved.
__________________

__________________
bshenanagins is offline   Reply With Quote
Reply

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off








» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.