Go Back   Aquarium Advice - Aquarium Forum Community > General Aquarium Forums > General Hardware/Equipment Discussion
Click Here to Login

Join Aquarium Advice Today
Reply
 
Thread Tools Search this Thread Display Modes
Please support our sponsors and let them know you heard about them on AquariumAdvice.com
 
Old 04-16-2008, 12:15 PM   #1
Aquarium Advice Addict
 
Join Date: Nov 2006
Posts: 2,254
Rena XP3 Parts

My filter is over a year old now and I've been noticing more vibration noise from it. I had the power go out for a short while and sometimes the filter won't reprime itself. It's quite loud then. I can remove the cap and put it back on and everything seems to be fine, but I am getting that additional noise. Can anyone recommend which parts to purchase and where to purchase them?

Thanks in advance.
__________________

__________________

theotheragentm is offline   Reply With Quote
Old 04-16-2008, 03:31 PM   #2
Sliced Bread
 
neilanh's Avatar


 
Join Date: Dec 2006
Location: Northern Virginia
Posts: 8,482
I've never dealt with this, but just hearing your issues I'd suspect the impeller. Losing power where it can't prime itself and getting noisy - that just points to either the impeller (easy solution) or the motor (not so cheap solution) in my opinion.
__________________

__________________
~Neilan
In the DC Metro Area? Check out GWAPA and WAMAS
neilanh is offline   Reply With Quote
Old 04-16-2008, 06:15 PM   #3
Aquarium Advice Addict
 
Join Date: Nov 2006
Posts: 2,254
What is the circular disc that you lock into place with a 1/8th turn? That sometimes gets dislodged, which makes a ton of noise when that's out, because the pump isn't working. i may just replace the impeller, shaft, and that piece.
__________________

theotheragentm is offline   Reply With Quote
Old 04-16-2008, 06:16 PM   #4
Sliced Bread
 
neilanh's Avatar


 
Join Date: Dec 2006
Location: Northern Virginia
Posts: 8,482
I think that piece just holds the impeller in place IIRC.

Makes me realize it's been a while since I cleaned out my impellers. lol
__________________
~Neilan
In the DC Metro Area? Check out GWAPA and WAMAS
neilanh is offline   Reply With Quote
Old 04-18-2008, 01:38 PM   #5
Aquarium Advice Addict
 
Join Date: Nov 2006
Posts: 2,254
Well I came home and the filter was still running fine. Two minutes later it was rattling. I opened it up and the circular disc was loose. I purchased a new one. Hopefully that solves my issues, because if this keeps coming loose, I'm going to end up burning out my motor.
__________________

theotheragentm is offline   Reply With Quote
Reply

Tags
rena, xp3

Please support our sponsors and let them know you heard about them on AquariumAdvice.com

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rena XP3 Not Working! GouramiFanatic General Hardware/Equipment Discussion 14 11-29-2008 06:41 PM
Used Rena XP3 bs6749 Archive 3 04-30-2008 12:12 AM
Rena XP3 help! Cliffz General Hardware/Equipment Discussion 6 10-09-2007 10:13 PM
rena xp3 chasingtime General Hardware/Equipment Discussion 6 11-19-2004 10:57 PM
Rena Xp3 Filstar moejoephd General Hardware/Equipment Discussion 2 09-05-2004 01:09 PM







» Photo Contest Winners








Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 08:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.